sensitivityio: File List

sensitivityio 1.1.1
sensitivity.io - Pluggable Security
File List
Here is a list of all files with brief descriptions:
[detail level 1234]
▼ sensitivityio
▼ config
▼ compiler
clang.hpp
gcc.hpp
msvc.hpp
▼ platform
linux.hpp
macosx.hpp
unix.hpp
windows.hpp
▼ platform_compiler
linux_gcc.hpp
macosx_clang.hpp
macosx_gcc.hpp
unix_clang.hpp
unix_gcc.hpp
windows_msvc.hpp
compiler.hpp
config.hpp
features.hpp
info.hpp
platform.hpp
platform_compiler.hpp
product_info.hpp
third_party.hpp
▼ php_base
application_id_retriever.h
config.h
errno.h
http_retriever.h
php_base.h
version.h
▼ php_license
config.h
license_loader.h
license_retriever.h
php_license.h
settings_loader.h
settings_retriever.h
▼ php_sdc
classification.h
classifier.h
classifier_settings_loader.h
classifier_settings_retriever.h
config.h
php_sdc.h
▼ php_sds
config.h
php_sds.h
scanner.h
scanner_settings_loader.h
scanner_settings_retriever.h
sds_threat_type.h
threat_info.h
threat_infos.h
threat_location.h
Generated by doxygen 1.8.13


sensitivityio: sensitivityio Directory Reference

  • sensitivityio
sensitivityio Directory Reference

Directories

directory | config
directory | php_base
directory | php_license
directory | php_sdc
directory | php_sds


sensitivityio: sensitivityio/config Directory Reference

  • config
config Directory Reference

Directories

directory | compiler
directory | platform
directory | platform_compiler

Files

file | compiler.hpp [code]
file | config.hpp [code]
file | features.hpp [code]
file | info.hpp [code]
file | platform.hpp [code]
file | platform_compiler.hpp [code]
file | product_info.hpp [code]
file | third_party.hpp [code]


sensitivityio: sensitivityio/config/compiler Directory Reference

  • config
  • compiler
compiler Directory Reference

Files

file | clang.hpp [code]
file | gcc.hpp [code]
file | msvc.hpp [code]


sensitivityio: sensitivityio/config/compiler/clang.hpp File Reference

  • config
  • compiler
clang.hpp File Reference
#include <cppdevtk/config/compiler.hpp>

Go to the source code of this file.

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file clang.hpp.


sensitivityio: sensitivityio/config/compiler/gcc.hpp File Reference

  • config
  • compiler
gcc.hpp File Reference
#include <cppdevtk/config/compiler.hpp>

Go to the source code of this file.

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file gcc.hpp.


sensitivityio: sensitivityio/config/compiler/msvc.hpp File Reference

  • config
  • compiler
msvc.hpp File Reference
#include <cppdevtk/config/compiler.hpp>

Go to the source code of this file.

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file msvc.hpp.


sensitivityio: sensitivityio/config/platform Directory Reference

  • config
  • platform
platform Directory Reference

Files

file | linux.hpp [code]
file | macosx.hpp [code]
file | unix.hpp [code]
file | windows.hpp [code]


sensitivityio: sensitivityio/config/platform/linux.hpp File Reference

  • config
  • platform
linux.hpp File Reference
#include "unix.hpp"
#include <cppdevtk/config/platform.hpp>

Go to the source code of this file.

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file linux.hpp.


sensitivityio: sensitivityio/config/platform/macosx.hpp File Reference

  • config
  • platform
macosx.hpp File Reference
#include "unix.hpp"
#include <cppdevtk/config/platform.hpp>

Go to the source code of this file.

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file macosx.hpp.


sensitivityio: sensitivityio/config/platform/unix.hpp File Reference

  • config
  • platform
unix.hpp File Reference

Go to the source code of this file.

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file unix.hpp.


sensitivityio: sensitivityio/config/platform/windows.hpp File Reference

  • config
  • platform
windows.hpp File Reference
#include <cppdevtk/config/platform.hpp>

Go to the source code of this file.

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file windows.hpp.


sensitivityio: sensitivityio/config/platform_compiler Directory Reference

  • config
  • platform_compiler
platform_compiler Directory Reference

Files

file | linux_gcc.hpp [code]
file | macosx_clang.hpp [code]
file | macosx_gcc.hpp [code]
file | unix_clang.hpp [code]
file | unix_gcc.hpp [code]
file | windows_msvc.hpp [code]


sensitivityio: sensitivityio/config/platform_compiler/linux_gcc.hpp File Reference

  • config
  • platform_compiler
linux_gcc.hpp File Reference
#include "unix_gcc.hpp"
#include <cppdevtk/config/platform_compiler.hpp>

Go to the source code of this file.

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file linux_gcc.hpp.


sensitivityio: sensitivityio/config/platform_compiler/macosx_clang.hpp File Reference

  • config
  • platform_compiler
macosx_clang.hpp File Reference
#include "unix_clang.hpp"
#include <cppdevtk/config/platform_compiler.hpp>

Go to the source code of this file.

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file macosx_clang.hpp.


sensitivityio: sensitivityio/config/platform_compiler/macosx_gcc.hpp File Reference

  • config
  • platform_compiler
macosx_gcc.hpp File Reference
#include "unix_gcc.hpp"
#include <cppdevtk/config/platform_compiler.hpp>

Go to the source code of this file.

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file macosx_gcc.hpp.


sensitivityio: sensitivityio/config/platform_compiler/unix_clang.hpp File Reference

  • config
  • platform_compiler
unix_clang.hpp File Reference

Go to the source code of this file.

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file unix_clang.hpp.


sensitivityio: sensitivityio/config/platform_compiler/unix_gcc.hpp File Reference

  • config
  • platform_compiler
unix_gcc.hpp File Reference

Go to the source code of this file.

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file unix_gcc.hpp.


sensitivityio: sensitivityio/config/platform_compiler/windows_msvc.hpp File Reference

  • config
  • platform_compiler
windows_msvc.hpp File Reference
#include <cppdevtk/config/platform_compiler.hpp>

Go to the source code of this file.

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file windows_msvc.hpp.


sensitivityio: sensitivityio/config/compiler.hpp File Reference

  • config
compiler.hpp File Reference
#include "features.hpp"
#include <cppdevtk/config/compiler.hpp>

Go to the source code of this file.

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file compiler.hpp.


sensitivityio: sensitivityio/config/config.hpp File Reference

  • config
config.hpp File Reference
#include "features.hpp"
#include "product_info.hpp"
#include "info.hpp"
#include "compiler.hpp"
#include "platform.hpp"
#include "platform_compiler.hpp"
#include "third_party.hpp"
#include <cppdevtk/util/config.hpp>

Go to the source code of this file.

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file config.hpp.


sensitivityio: sensitivityio/config/features.hpp File Reference

  • config
Macros
features.hpp File Reference
#include <cppdevtk/config/features.hpp>

Go to the source code of this file.

Macros

#define | SENSITIVITYIO_DISABLE_THIRD_PARTY_WARNINGS 0
#define | SENSITIVITYIO_DISABLE_SENSITIVITYIO_WARNINGS 0
#define | SENSITIVITYIO_FORCE_DBC_IN_CLIENT_API 1

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file features.hpp.

Macro Definition Documentation

◆ SENSITIVITYIO_DISABLE_SENSITIVITYIO_WARNINGS

#define SENSITIVITYIO_DISABLE_SENSITIVITYIO_WARNINGS 0

Definition at line 36 of file features.hpp.

◆ SENSITIVITYIO_DISABLE_THIRD_PARTY_WARNINGS

#define SENSITIVITYIO_DISABLE_THIRD_PARTY_WARNINGS 0

Definition at line 28 of file features.hpp.

◆ SENSITIVITYIO_FORCE_DBC_IN_CLIENT_API

#define SENSITIVITYIO_FORCE_DBC_IN_CLIENT_API 1

Definition at line 41 of file features.hpp.


sensitivityio: sensitivityio/config/info.hpp File Reference

  • config
info.hpp File Reference
#include "features.hpp"
#include "product_info.hpp"
#include <cppdevtk/config/company_info.hpp>

Go to the source code of this file.

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file info.hpp.


sensitivityio: sensitivityio/config/platform.hpp File Reference

  • config
platform.hpp File Reference
#include "features.hpp"
#include "compiler.hpp"
#include <cppdevtk/config/platform.hpp>

Go to the source code of this file.

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file platform.hpp.


sensitivityio: sensitivityio/config/platform_compiler.hpp File Reference

  • config
platform_compiler.hpp File Reference
#include "features.hpp"
#include "compiler.hpp"
#include "platform.hpp"
#include <cppdevtk/config/platform_compiler.hpp>

Go to the source code of this file.

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file platform_compiler.hpp.


sensitivityio: sensitivityio/config/product_info.hpp File Reference

  • config
Macros
product_info.hpp File Reference
#include "features.hpp"
#include <cppdevtk/config/info.hpp>

Go to the source code of this file.

Macros

#define | SENSITIVITYIO_VERSION_MAJOR 1
#define | SENSITIVITYIO_VERSION_MINOR 1
#define | SENSITIVITYIO_VERSION_PATCH 1
#define | SENSITIVITYIO_VERSION_NUMBER CPPDEVTK_VERSION_NUMBER_FROM_COMPONENTS(SENSITIVITYIO_VERSION_MAJOR, SENSITIVITYIO_VERSION_MINOR, SENSITIVITYIO_VERSION_PATCH)
#define | SENSITIVITYIO_VERSION_STRING CPPDEVTK_VERSION_STRING_FROM_COMPONENTS(SENSITIVITYIO_VERSION_MAJOR, SENSITIVITYIO_VERSION_MINOR, SENSITIVITYIO_VERSION_PATCH)
#define | SENSITIVITYIO_SHORT_NAME "sensitivityio"
#define | SENSITIVITYIO_SHORT_NAME_SANITIZED QString(SENSITIVITYIO_SHORT_NAME).toLower().replace(' ', '_')
#define | SENSITIVITYIO_LONG_NAME "sensitivity.io - Data Loss Prevention APIs for Developers"
#define | SENSITIVITYIO_LONG_NAME_SANITIZED QString(SENSITIVITYIO_LONG_NAME).toLower().replace(' ', '_')
#define | SENSITIVITYIO_DESCRIPTION "sensitivity.io is a Security as a Service Platform."
#define | SENSITIVITYIO_COPYRIGHT "Copyright (C) 2017 " CPPDEVTK_COMPANY_LONG_NAME ". All rights reserved. " CPPDEVTK_COMPANY_EMAIL "."
#define | SENSITIVITYIO_TRADEMARKS CPPDEVTK_COMPANY_TRADEMARKS
#define | SENSITIVITYIO_HOMEPAGE "https://sensitivity.io"
#define | SENSITIVITYIO_ONLINE_SUPPORT "https://sensitivity.io/support"
#define | SENSITIVITYIO_ONLINE_REGISTRATION "https://sensitivity.io/register"
#define | SENSITIVITYIO_ESTORE "https://sensitivity.io/buy"
#define | SENSITIVITYIO_EMAIL "team@sensitivity.io"

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file product_info.hpp.

Macro Definition Documentation

◆ SENSITIVITYIO_COPYRIGHT

#define SENSITIVITYIO_COPYRIGHT "Copyright (C) 2017 " CPPDEVTK_COMPANY_LONG_NAME ". All rights reserved. " CPPDEVTK_COMPANY_EMAIL "."

Definition at line 50 of file product_info.hpp.

◆ SENSITIVITYIO_DESCRIPTION

#define SENSITIVITYIO_DESCRIPTION "sensitivity.io is a Security as a Service Platform."

Definition at line 49 of file product_info.hpp.

◆ SENSITIVITYIO_EMAIL

#define SENSITIVITYIO_EMAIL "team@sensitivity.io"

Definition at line 56 of file product_info.hpp.

◆ SENSITIVITYIO_ESTORE

#define SENSITIVITYIO_ESTORE "https://sensitivity.io/buy"

Definition at line 55 of file product_info.hpp.

◆ SENSITIVITYIO_HOMEPAGE

#define SENSITIVITYIO_HOMEPAGE "https://sensitivity.io"

Definition at line 52 of file product_info.hpp.

◆ SENSITIVITYIO_LONG_NAME

#define SENSITIVITYIO_LONG_NAME "sensitivity.io - Data Loss Prevention APIs for Developers"

Definition at line 47 of file product_info.hpp.

◆ SENSITIVITYIO_LONG_NAME_SANITIZED

#define SENSITIVITYIO_LONG_NAME_SANITIZED QString(SENSITIVITYIO_LONG_NAME).toLower().replace(' ', '_')

Definition at line 48 of file product_info.hpp.

◆ SENSITIVITYIO_ONLINE_REGISTRATION

#define SENSITIVITYIO_ONLINE_REGISTRATION "https://sensitivity.io/register"

Definition at line 54 of file product_info.hpp.

◆ SENSITIVITYIO_ONLINE_SUPPORT

#define SENSITIVITYIO_ONLINE_SUPPORT "https://sensitivity.io/support"

Definition at line 53 of file product_info.hpp.

◆ SENSITIVITYIO_SHORT_NAME

#define SENSITIVITYIO_SHORT_NAME "sensitivityio"

Definition at line 45 of file product_info.hpp.

◆ SENSITIVITYIO_SHORT_NAME_SANITIZED

#define SENSITIVITYIO_SHORT_NAME_SANITIZED QString(SENSITIVITYIO_SHORT_NAME).toLower().replace(' ', '_')

Definition at line 46 of file product_info.hpp.

◆ SENSITIVITYIO_TRADEMARKS

#define SENSITIVITYIO_TRADEMARKS CPPDEVTK_COMPANY_TRADEMARKS

Definition at line 51 of file product_info.hpp.

◆ SENSITIVITYIO_VERSION_MAJOR

#define SENSITIVITYIO_VERSION_MAJOR 1

Definition at line 30 of file product_info.hpp.

◆ SENSITIVITYIO_VERSION_MINOR

#define SENSITIVITYIO_VERSION_MINOR 1

Definition at line 31 of file product_info.hpp.

◆ SENSITIVITYIO_VERSION_NUMBER

#define SENSITIVITYIO_VERSION_NUMBER CPPDEVTK_VERSION_NUMBER_FROM_COMPONENTS(SENSITIVITYIO_VERSION_MAJOR, SENSITIVITYIO_VERSION_MINOR, SENSITIVITYIO_VERSION_PATCH)

Definition at line 38 of file product_info.hpp.

◆ SENSITIVITYIO_VERSION_PATCH

#define SENSITIVITYIO_VERSION_PATCH 1

Definition at line 32 of file product_info.hpp.

◆ SENSITIVITYIO_VERSION_STRING

#define SENSITIVITYIO_VERSION_STRING CPPDEVTK_VERSION_STRING_FROM_COMPONENTS(SENSITIVITYIO_VERSION_MAJOR, SENSITIVITYIO_VERSION_MINOR, SENSITIVITYIO_VERSION_PATCH)

Definition at line 41 of file product_info.hpp.


sensitivityio: sensitivityio/config/third_party.hpp File Reference

  • config
Macros
third_party.hpp File Reference
#include "features.hpp"
#include "platform_compiler.hpp"
#include <curl/curlver.h>
#include <cppdevtk/config/third_party.hpp>

Go to the source code of this file.

Macros

#define | SENSITIVITYIO_HAVE_CHARDET 0
#define | SENSITIVITYIO_HAVE_CURL 1
#define | CURL_VERSION_BITS(x, y, z) ((x)<<16|(y)<<8|z)
#define | CURL_AT_LEAST_VERSION(x, y, z) (LIBCURL_VERSION_NUM >= CURL_VERSION_BITS(x, y, z))
#define | SENSITIVITYIO_HAVE_APACHE_TIKA (1 && SENSITIVITYIO_BASE_ENABLE_JNI)

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file third_party.hpp.

Macro Definition Documentation

◆ CURL_AT_LEAST_VERSION

#define CURL_AT_LEAST_VERSION | ( | x,
 |  | y,
 |  | z
 | ) | (LIBCURL_VERSION_NUM >= CURL_VERSION_BITS(x, y, z))

Definition at line 56 of file third_party.hpp.

◆ CURL_VERSION_BITS

#define CURL_VERSION_BITS | ( | x,
 |  | y,
 |  | z
 | ) | ((x)<<16|(y)<<8|z)

Definition at line 53 of file third_party.hpp.

◆ SENSITIVITYIO_HAVE_APACHE_TIKA

#define SENSITIVITYIO_HAVE_APACHE_TIKA (1 && SENSITIVITYIO_BASE_ENABLE_JNI)

Definition at line 107 of file third_party.hpp.

◆ SENSITIVITYIO_HAVE_CHARDET

#define SENSITIVITYIO_HAVE_CHARDET 0

Definition at line 25 of file third_party.hpp.

◆ SENSITIVITYIO_HAVE_CURL

#define SENSITIVITYIO_HAVE_CURL 1

Definition at line 26 of file third_party.hpp.


sensitivityio: sensitivityio/php_base Directory Reference

  • php_base
php_base Directory Reference

Files

file | application_id_retriever.h [code]
file | config.h [code]
file | errno.h [code]
file | http_retriever.h [code]
file | php_base.h [code]
file | version.h [code]


sensitivityio: sensitivityio/php_base/application_id_retriever.h File Reference

  • php_base
Functions
application_id_retriever.h File Reference
#include "config.h"
#include "http_retriever.h"

Go to the source code of this file.

Functions

PHP_FUNCTION (sensitivityio_php_application_id_retriever_get_instance)
sensitivityio_php_http_retriever_t sensitivityio_php_application_id_retriever_get_instance(); More...
PHP_FUNCTION (sensitivityio_php_application_id_retriever_retrieve_application_id)

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file application_id_retriever.h.

Function Documentation

◆ PHP_FUNCTION() [1/2]

PHP_FUNCTION ( sensitivityio_php_application_id_retriever_get_instance )

sensitivityio_php_http_retriever_t sensitivityio_php_application_id_retriever_get_instance();

◆ PHP_FUNCTION() [2/2]

PHP_FUNCTION ( sensitivityio_php_application_id_retriever_retrieve_application_id )

boolean sensitivityio_php_application_id_retriever_retrieve_application_id(sensitivityio_php_http_retriever_t $retriever);

Remarks
Relevant errno: ENETUNREACH, EPROTO


sensitivityio: sensitivityio/php_base/config.h File Reference

  • php_base
Macros
config.h File Reference
#include <sensitivityio/config/config.hpp>
#include <php_version.h>
#include <php.h>
#include <zend_modules.h>

Go to the source code of this file.

Macros

#define | PHP_FE_END {NULL, NULL, NULL, 0, 0}
#define | SENSITIVITYIO_PHP_BASE_API
#define | SENSITIVITYIO_PHP_BASE_VERSION SENSITIVITYIO_VERSION_STRING
#define | phpext_sensitivityio_php_base_ptr &sensitivityio_php_base_module_entry
#define | SENSITIVITYIO_PHP_BASE_G(v) (sensitivityio_php_base_globals.v)

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file config.h.

Macro Definition Documentation

◆ PHP_FE_END

#define PHP_FE_END {NULL, NULL, NULL, 0, 0}

Definition at line 83 of file config.h.

◆ phpext_sensitivityio_php_base_ptr

#define phpext_sensitivityio_php_base_ptr &sensitivityio_php_base_module_entry

Definition at line 98 of file config.h.

◆ SENSITIVITYIO_PHP_BASE_API

#define SENSITIVITYIO_PHP_BASE_API

Definition at line 92 of file config.h.

◆ SENSITIVITYIO_PHP_BASE_G

#define SENSITIVITYIO_PHP_BASE_G ( v ) (sensitivityio_php_base_globals.v)

Definition at line 112 of file config.h.

◆ SENSITIVITYIO_PHP_BASE_VERSION

#define SENSITIVITYIO_PHP_BASE_VERSION SENSITIVITYIO_VERSION_STRING

Definition at line 96 of file config.h.


sensitivityio: sensitivityio/php_base/errno.h File Reference

  • php_base
Functions
errno.h File Reference
#include "config.h"

Go to the source code of this file.

Functions

PHP_FUNCTION (sensitivityio_php_get_errno)
integer sensitivityio_php_get_errno(); More...
PHP_FUNCTION (sensitivityio_php_get_errmsg)
string sensitivityio_php_get_errmsg(integer errNo); More...

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com
Note
The API is POSIX style:
  • Functions that return pointer will return NULL in case of error.
  • Functions that return int will return SENSITIVITYIO_SUCCESS or SENSITIVITYIO_ERROR.
  • Both types of functions in case of error will set errno appropriately.
errno: ENOENT, EIO, ECANCELED, EINVAL, ENOMEM For remaining cases logic errors are mapped to EPROTO, runtime errors, exception and unknown exceptions are mapped to ENODATA
Filesystem paths must be in Qt format (use / as path separator)

Definition in file errno.h.

Function Documentation

◆ PHP_FUNCTION() [1/2]

PHP_FUNCTION ( sensitivityio_php_get_errno )

integer sensitivityio_php_get_errno();

◆ PHP_FUNCTION() [2/2]

PHP_FUNCTION ( sensitivityio_php_get_errmsg )

string sensitivityio_php_get_errmsg(integer errNo);


sensitivityio: sensitivityio/php_base/http_retriever.h File Reference

  • php_base
Macros | Functions | Variables
http_retriever.h File Reference
#include "config.h"

Go to the source code of this file.

Macros

#define SENSITIVITYIO_PHP_HTTP_RETRIEVER_RES_NAME "SENSITIVITYIO_PHP_HTTP_RETRIEVER"

Functions

PHP_FUNCTION (sensitivityio_php_http_retriever_get_host_name)
string sensitivityio_php_http_retriever_get_host_name(); If not set, default is api.sensitivity.io More...
PHP_FUNCTION (sensitivityio_php_http_retriever_set_host_name)
boolean sensitivityio_php_http_retriever_set_host_name(string $hostName); More...
PHP_FUNCTION (sensitivityio_php_http_retriever_get_api_ver)
string sensitivityio_php_http_retriever_get_api_ver(); If not set, default is v1 More...
PHP_FUNCTION (sensitivityio_php_http_retriever_set_api_ver)
boolean sensitivityio_php_http_retriever_set_api_ver(string $apiVer); More...
PHP_FUNCTION (sensitivityio_php_http_retriever_get_account_id)
string sensitivityio_php_http_retriever_get_account_id(); More...
PHP_FUNCTION (sensitivityio_php_http_retriever_set_account_id)
boolean sensitivityio_php_http_retriever_set_account_id(string $accountId); More...
PHP_FUNCTION (sensitivityio_php_http_retriever_get_project_id)
string sensitivityio_php_http_retriever_get_project_id(); More...
PHP_FUNCTION (sensitivityio_php_http_retriever_set_project_id)
boolean sensitivityio_php_http_retriever_set_project_id(string $projectId); More...
PHP_FUNCTION (sensitivityio_php_http_retriever_get_authentication_key)
string sensitivityio_php_http_retriever_get_authentication_key(); More...
PHP_FUNCTION (sensitivityio_php_http_retriever_set_authentication_key)
boolean sensitivityio_php_http_retriever_set_authentication_key(string $authenticationKey); More...
PHP_FUNCTION (sensitivityio_php_http_retriever_get_application_id)
string sensitivityio_php_http_retriever_get_application_id(); More...
PHP_FUNCTION (sensitivityio_php_http_retriever_set_application_id)
boolean sensitivityio_php_http_retriever_set_application_id(string $applicationId); More...
PHP_FUNCTION (sensitivityio_php_http_retriever_get_destination_file)
string sensitivityio_php_http_retriever_get_destination_file(sensitivityio_php_http_retriever_t $httpRetriever); More...
PHP_FUNCTION (sensitivityio_php_http_retriever_set_destination_file)
boolean sensitivityio_php_http_retriever_set_destination_file(sensitivityio_php_http_retriever_t $httpRetriever, string $destinationFile); More...
PHP_FUNCTION (sensitivityio_php_http_retriever_get_url)
string sensitivityio_php_http_retriever_get_url(sensitivityio_php_http_retriever_t $httpRetriever); More...
PHP_FUNCTION (sensitivityio_php_http_retriever_retrieve_to_string)
PHP_FUNCTION (sensitivityio_php_http_retriever_retrieve_to_file)

Variables

int le_sensitivityio_php_http_retriever

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file http_retriever.h.

Macro Definition Documentation

◆ SENSITIVITYIO_PHP_HTTP_RETRIEVER_RES_NAME

#define SENSITIVITYIO_PHP_HTTP_RETRIEVER_RES_NAME "SENSITIVITYIO_PHP_HTTP_RETRIEVER"

Definition at line 19 of file http_retriever.h.

Function Documentation

◆ PHP_FUNCTION() [1/17]

PHP_FUNCTION ( sensitivityio_php_http_retriever_get_host_name )

string sensitivityio_php_http_retriever_get_host_name(); If not set, default is api.sensitivity.io

◆ PHP_FUNCTION() [2/17]

PHP_FUNCTION ( sensitivityio_php_http_retriever_set_host_name )

boolean sensitivityio_php_http_retriever_set_host_name(string $hostName);

◆ PHP_FUNCTION() [3/17]

PHP_FUNCTION ( sensitivityio_php_http_retriever_get_api_ver )

string sensitivityio_php_http_retriever_get_api_ver(); If not set, default is v1

◆ PHP_FUNCTION() [4/17]

PHP_FUNCTION ( sensitivityio_php_http_retriever_set_api_ver )

boolean sensitivityio_php_http_retriever_set_api_ver(string $apiVer);

◆ PHP_FUNCTION() [5/17]

PHP_FUNCTION ( sensitivityio_php_http_retriever_get_account_id )

string sensitivityio_php_http_retriever_get_account_id();

◆ PHP_FUNCTION() [6/17]

PHP_FUNCTION ( sensitivityio_php_http_retriever_set_account_id )

boolean sensitivityio_php_http_retriever_set_account_id(string $accountId);

◆ PHP_FUNCTION() [7/17]

PHP_FUNCTION ( sensitivityio_php_http_retriever_get_project_id )

string sensitivityio_php_http_retriever_get_project_id();

◆ PHP_FUNCTION() [8/17]

PHP_FUNCTION ( sensitivityio_php_http_retriever_set_project_id )

boolean sensitivityio_php_http_retriever_set_project_id(string $projectId);

◆ PHP_FUNCTION() [9/17]

PHP_FUNCTION ( sensitivityio_php_http_retriever_get_authentication_key )

string sensitivityio_php_http_retriever_get_authentication_key();

◆ PHP_FUNCTION() [10/17]

PHP_FUNCTION ( sensitivityio_php_http_retriever_set_authentication_key )

boolean sensitivityio_php_http_retriever_set_authentication_key(string $authenticationKey);

◆ PHP_FUNCTION() [11/17]

PHP_FUNCTION ( sensitivityio_php_http_retriever_get_application_id )

string sensitivityio_php_http_retriever_get_application_id();

◆ PHP_FUNCTION() [12/17]

PHP_FUNCTION ( sensitivityio_php_http_retriever_set_application_id )

boolean sensitivityio_php_http_retriever_set_application_id(string $applicationId);

◆ PHP_FUNCTION() [13/17]

PHP_FUNCTION ( sensitivityio_php_http_retriever_get_destination_file )

string sensitivityio_php_http_retriever_get_destination_file(sensitivityio_php_http_retriever_t $httpRetriever);

◆ PHP_FUNCTION() [14/17]

PHP_FUNCTION ( sensitivityio_php_http_retriever_set_destination_file )

boolean sensitivityio_php_http_retriever_set_destination_file(sensitivityio_php_http_retriever_t $httpRetriever, string $destinationFile);

◆ PHP_FUNCTION() [15/17]

PHP_FUNCTION ( sensitivityio_php_http_retriever_get_url )

string sensitivityio_php_http_retriever_get_url(sensitivityio_php_http_retriever_t $httpRetriever);

◆ PHP_FUNCTION() [16/17]

PHP_FUNCTION ( sensitivityio_php_http_retriever_retrieve_to_string )

string sensitivityio_php_http_retriever_retrieve_to_string(sensitivityio_php_http_retriever_t $httpRetriever);

Remarks
Relevant errno: ENETUNREACH, EPROTO

◆ PHP_FUNCTION() [17/17]

PHP_FUNCTION ( sensitivityio_php_http_retriever_retrieve_to_file )

boolean sensitivityio_php_http_retriever_retrieve_to_file(sensitivityio_php_http_retriever_t $httpRetriever);

Remarks
Relevant errno: ENETUNREACH, EPROTO, EIO

Variable Documentation

◆ le_sensitivityio_php_http_retriever

int le_sensitivityio_php_http_retriever


sensitivityio: sensitivityio/php_base/php_base.h File Reference

  • php_base
Functions | Variables
php_base.h File Reference
#include "config.h"

Go to the source code of this file.

Functions

PHP_MINIT_FUNCTION (sensitivityio_php_base)
PHP_MSHUTDOWN_FUNCTION (sensitivityio_php_base)
PHP_RINIT_FUNCTION (sensitivityio_php_base)
PHP_RSHUTDOWN_FUNCTION (sensitivityio_php_base)
PHP_MINFO_FUNCTION (sensitivityio_php_base)

Variables

zend_module_entry sensitivityio_php_base_module_entry

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file php_base.h.

Function Documentation

◆ PHP_MINFO_FUNCTION()

PHP_MINFO_FUNCTION ( sensitivityio_php_base )

◆ PHP_MINIT_FUNCTION()

PHP_MINIT_FUNCTION ( sensitivityio_php_base )

◆ PHP_MSHUTDOWN_FUNCTION()

PHP_MSHUTDOWN_FUNCTION ( sensitivityio_php_base )

◆ PHP_RINIT_FUNCTION()

PHP_RINIT_FUNCTION ( sensitivityio_php_base )

◆ PHP_RSHUTDOWN_FUNCTION()

PHP_RSHUTDOWN_FUNCTION ( sensitivityio_php_base )

Variable Documentation

◆ sensitivityio_php_base_module_entry

zend_module_entry sensitivityio_php_base_module_entry


sensitivityio: sensitivityio/php_base/version.h File Reference

  • php_base
Functions
version.h File Reference
#include "config.h"

Go to the source code of this file.

Functions

PHP_FUNCTION (sensitivityio_php_get_version_major)
integer sensitivityio_php_get_version_major(); More...
PHP_FUNCTION (sensitivityio_php_get_version_minor)
integer sensitivityio_php_get_version_minor(); More...
PHP_FUNCTION (sensitivityio_php_get_version_patch)
integer sensitivityio_php_get_version_patch(); More...
PHP_FUNCTION (sensitivityio_php_get_version_number)
integer sensitivityio_php_get_version_number(); More...
PHP_FUNCTION (sensitivityio_php_get_version_string)
string sensitivityio_php_get_version_string(); More...

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file version.h.

Function Documentation

◆ PHP_FUNCTION() [1/5]

PHP_FUNCTION ( sensitivityio_php_get_version_major )

integer sensitivityio_php_get_version_major();

◆ PHP_FUNCTION() [2/5]

PHP_FUNCTION ( sensitivityio_php_get_version_minor )

integer sensitivityio_php_get_version_minor();

◆ PHP_FUNCTION() [3/5]

PHP_FUNCTION ( sensitivityio_php_get_version_patch )

integer sensitivityio_php_get_version_patch();

◆ PHP_FUNCTION() [4/5]

PHP_FUNCTION ( sensitivityio_php_get_version_number )

integer sensitivityio_php_get_version_number();

◆ PHP_FUNCTION() [5/5]

PHP_FUNCTION ( sensitivityio_php_get_version_string )

string sensitivityio_php_get_version_string();


sensitivityio: sensitivityio/php_license Directory Reference

  • php_license
php_license Directory Reference

Files

file | config.h [code]
file | license_loader.h [code]
file | license_retriever.h [code]
file | php_license.h [code]
file | settings_loader.h [code]
file | settings_retriever.h [code]


sensitivityio: sensitivityio/php_license/config.h File Reference

  • php_license
Macros
config.h File Reference
#include <sensitivityio/php_base/config.h>
#include <php.h>
#include <zend_modules.h>

Go to the source code of this file.

Macros

#define | SENSITIVITYIO_PHP_LICENSE_API
#define | SENSITIVITYIO_PHP_LICENSE_VERSION SENSITIVITYIO_VERSION_STRING
#define | phpext_sensitivityio_php_license_ptr &sensitivityio_php_license_module_entry
#define | SENSITIVITYIO_PHP_LICENSE_G(v) (sensitivityio_php_license_globals.v)

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file config.h.

Macro Definition Documentation

◆ phpext_sensitivityio_php_license_ptr

#define phpext_sensitivityio_php_license_ptr &sensitivityio_php_license_module_entry

Definition at line 36 of file config.h.

◆ SENSITIVITYIO_PHP_LICENSE_API

#define SENSITIVITYIO_PHP_LICENSE_API

Definition at line 30 of file config.h.

◆ SENSITIVITYIO_PHP_LICENSE_G

#define SENSITIVITYIO_PHP_LICENSE_G ( v ) (sensitivityio_php_license_globals.v)

Definition at line 50 of file config.h.

◆ SENSITIVITYIO_PHP_LICENSE_VERSION

#define SENSITIVITYIO_PHP_LICENSE_VERSION SENSITIVITYIO_VERSION_STRING

Definition at line 34 of file config.h.


sensitivityio: sensitivityio/php_license/license_loader.h File Reference

  • php_license
Macros | Functions | Variables
license_loader.h File Reference
#include "config.h"

Go to the source code of this file.

Macros

#define SENSITIVITYIO_PHP_LICENSE_LOADER_RES_NAME "SENSITIVITYIO_PHP_LICENSE_LOADER"

Functions

PHP_FUNCTION (sensitivityio_php_license_loader_get_instance)
sensitivityio_php_license_loader_t sensitivityio_php_license_loader_get_instance(); More...
PHP_FUNCTION (sensitivityio_php_license_loader_load_license_from_string)
PHP_FUNCTION (sensitivityio_php_license_loader_load_license_from_file)

Variables

int le_sensitivityio_php_license_loader

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file license_loader.h.

Macro Definition Documentation

◆ SENSITIVITYIO_PHP_LICENSE_LOADER_RES_NAME

#define SENSITIVITYIO_PHP_LICENSE_LOADER_RES_NAME "SENSITIVITYIO_PHP_LICENSE_LOADER"

Definition at line 20 of file license_loader.h.

Function Documentation

◆ PHP_FUNCTION() [1/3]

PHP_FUNCTION ( sensitivityio_php_license_loader_get_instance )

sensitivityio_php_license_loader_t sensitivityio_php_license_loader_get_instance();

◆ PHP_FUNCTION() [2/3]

PHP_FUNCTION ( sensitivityio_php_license_loader_load_license_from_string )

boolean sensitivityio_php_license_loader_load_license_from_string(string $license);

Remarks
Relevant errno: SENSITIVITYIO_EINVALIDLICENSE

◆ PHP_FUNCTION() [3/3]

PHP_FUNCTION ( sensitivityio_php_license_loader_load_license_from_file )

boolean sensitivityio_php_license_loader_load_license_from_file(string $licenseFileName);

Remarks
Relevant errno: SENSITIVITYIO_EINVALIDLICENSE, ENOENT, EIO

Variable Documentation

◆ le_sensitivityio_php_license_loader

int le_sensitivityio_php_license_loader


sensitivityio: sensitivityio/php_license/license_retriever.h File Reference

  • php_license
Functions
license_retriever.h File Reference
#include "config.h"
#include "license_loader.h"
#include <sensitivityio/php_base/http_retriever.h>

Go to the source code of this file.

Functions

PHP_FUNCTION (sensitivityio_php_license_retriever_get_instance)
sensitivityio_php_http_retriever_t sensitivityio_php_license_retriever_get_instance(void); More...
PHP_FUNCTION (sensitivityio_php_license_retriever_retrieve_to_string_and_notify_loader)
string sensitivityio_php_license_retriever_retrieve_to_string_and_notify_loader( sensitivityio_php_http_retriever_t $retriever); More...
PHP_FUNCTION (sensitivityio_php_license_retriever_retrieve_to_file_and_notify_loader)
boolean sensitivityio_php_license_retriever_retrieve_to_file_and_notify_loader( sensitivityio_php_http_retriever_t $retriever); More...

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file license_retriever.h.

Function Documentation

◆ PHP_FUNCTION() [1/3]

PHP_FUNCTION ( sensitivityio_php_license_retriever_get_instance )

sensitivityio_php_http_retriever_t sensitivityio_php_license_retriever_get_instance(void);

◆ PHP_FUNCTION() [2/3]

PHP_FUNCTION ( sensitivityio_php_license_retriever_retrieve_to_string_and_notify_loader )

string sensitivityio_php_license_retriever_retrieve_to_string_and_notify_loader( sensitivityio_php_http_retriever_t $retriever);

Remarks
Relevant errno: SENSITIVITYIO_EINVALIDLICENSE, ENETUNREACH, EPROTO

◆ PHP_FUNCTION() [3/3]

PHP_FUNCTION ( sensitivityio_php_license_retriever_retrieve_to_file_and_notify_loader )

boolean sensitivityio_php_license_retriever_retrieve_to_file_and_notify_loader( sensitivityio_php_http_retriever_t $retriever);

Remarks
Relevant errno: SENSITIVITYIO_EINVALIDLICENSE, ENETUNREACH, EPROTO, ENOENT, EIO


sensitivityio: sensitivityio/php_license/php_license.h File Reference

  • php_license
Functions | Variables
php_license.h File Reference
#include "config.h"

Go to the source code of this file.

Functions

PHP_MINIT_FUNCTION (sensitivityio_php_license)
PHP_MSHUTDOWN_FUNCTION (sensitivityio_php_license)
PHP_RINIT_FUNCTION (sensitivityio_php_license)
PHP_RSHUTDOWN_FUNCTION (sensitivityio_php_license)
PHP_MINFO_FUNCTION (sensitivityio_php_license)

Variables

zend_module_entry sensitivityio_php_license_module_entry

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file php_license.h.

Function Documentation

◆ PHP_MINFO_FUNCTION()

PHP_MINFO_FUNCTION ( sensitivityio_php_license )

◆ PHP_MINIT_FUNCTION()

PHP_MINIT_FUNCTION ( sensitivityio_php_license )

◆ PHP_MSHUTDOWN_FUNCTION()

PHP_MSHUTDOWN_FUNCTION ( sensitivityio_php_license )

◆ PHP_RINIT_FUNCTION()

PHP_RINIT_FUNCTION ( sensitivityio_php_license )

◆ PHP_RSHUTDOWN_FUNCTION()

PHP_RSHUTDOWN_FUNCTION ( sensitivityio_php_license )

Variable Documentation

◆ sensitivityio_php_license_module_entry

zend_module_entry sensitivityio_php_license_module_entry


sensitivityio: sensitivityio/php_license/settings_loader.h File Reference

  • php_license
Macros | Functions | Variables
settings_loader.h File Reference
#include "config.h"

Go to the source code of this file.

Macros

#define SENSITIVITYIO_PHP_SETTINGS_LOADER_RES_NAME "SENSITIVITYIO_PHP_SETTINGS_LOADER"

Functions

PHP_FUNCTION (sensitivityio_php_settings_loader_load_settings_from_string)
boolean sensitivityio_php_settings_loader_load_settings_from_string( sensitivityio_php_settings_loader_t $settingsLoader, string $settingsString); More...
PHP_FUNCTION (sensitivityio_php_settings_loader_load_settings_from_file)
boolean sensitivityio_php_settings_loader_load_settings_from_file( sensitivityio_php_settings_loader_t $settingsLoader, string $settingsFileName); More...

Variables

int le_sensitivityio_php_settings_loader

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file settings_loader.h.

Macro Definition Documentation

◆ SENSITIVITYIO_PHP_SETTINGS_LOADER_RES_NAME

#define SENSITIVITYIO_PHP_SETTINGS_LOADER_RES_NAME "SENSITIVITYIO_PHP_SETTINGS_LOADER"

Definition at line 19 of file settings_loader.h.

Function Documentation

◆ PHP_FUNCTION() [1/2]

PHP_FUNCTION ( sensitivityio_php_settings_loader_load_settings_from_string )

boolean sensitivityio_php_settings_loader_load_settings_from_string( sensitivityio_php_settings_loader_t $settingsLoader, string $settingsString);

Remarks
Relevant errno: SENSITIVITYIO_ESETTINGS

◆ PHP_FUNCTION() [2/2]

PHP_FUNCTION ( sensitivityio_php_settings_loader_load_settings_from_file )

boolean sensitivityio_php_settings_loader_load_settings_from_file( sensitivityio_php_settings_loader_t $settingsLoader, string $settingsFileName);

Remarks
Relevant errno: SENSITIVITYIO_ESETTINGS, ENOENT, EIO

Variable Documentation

◆ le_sensitivityio_php_settings_loader

int le_sensitivityio_php_settings_loader


sensitivityio: sensitivityio/php_license/settings_retriever.h File Reference

  • php_license
Functions
settings_retriever.h File Reference
#include "config.h"
#include "settings_loader.h"
#include <sensitivityio/php_base/http_retriever.h>

Go to the source code of this file.

Functions

PHP_FUNCTION (sensitivityio_php_settings_retriever_set_settings_loader)
boolean sensitivityio_php_settings_retriever_set_settings_loader(sensitivityio_php_http_retriever_t $retriever, sensitivityio_php_settings_loader_t $settingsLoader); More...
PHP_FUNCTION (sensitivityio_php_settings_retriever_retrieve_to_string_and_notify_loader)
string sensitivityio_php_settings_retriever_retrieve_to_string_and_notify_loader( sensitivityio_php_http_retriever_t $retriever); More...
PHP_FUNCTION (sensitivityio_php_settings_retriever_retrieve_to_file_and_notify_loader)
boolean sensitivityio_php_settings_retriever_retrieve_to_file_and_notify_loader( sensitivityio_php_http_retriever_t $retriever); More...

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file settings_retriever.h.

Function Documentation

◆ PHP_FUNCTION() [1/3]

PHP_FUNCTION ( sensitivityio_php_settings_retriever_set_settings_loader )

boolean sensitivityio_php_settings_retriever_set_settings_loader(sensitivityio_php_http_retriever_t $retriever, sensitivityio_php_settings_loader_t $settingsLoader);

◆ PHP_FUNCTION() [2/3]

PHP_FUNCTION ( sensitivityio_php_settings_retriever_retrieve_to_string_and_notify_loader )

string sensitivityio_php_settings_retriever_retrieve_to_string_and_notify_loader( sensitivityio_php_http_retriever_t $retriever);

Remarks
Relevant errno: SENSITIVITYIO_ESETTINGS, ENETUNREACH, EPROTO
Note
SettingsLoader is notified if not NULL

◆ PHP_FUNCTION() [3/3]

PHP_FUNCTION ( sensitivityio_php_settings_retriever_retrieve_to_file_and_notify_loader )

boolean sensitivityio_php_settings_retriever_retrieve_to_file_and_notify_loader( sensitivityio_php_http_retriever_t $retriever);

Remarks
Relevant errno: SENSITIVITYIO_ESETTINGS, ENETUNREACH, EPROTO, ENOENT, EIO
Note
SettingsLoader is notified if not NULL


sensitivityio: sensitivityio/php_sdc Directory Reference

  • php_sdc
php_sdc Directory Reference

Files

file | classification.h [code]
file | classifier.h [code]
file | classifier_settings_loader.h [code]
file | classifier_settings_retriever.h [code]
file | config.h [code]
file | php_sdc.h [code]


sensitivityio: sensitivityio/php_sdc/classification.h File Reference

  • php_sdc
Macros | Functions | Variables
classification.h File Reference
#include "config.h"

Go to the source code of this file.

Macros

#define SENSITIVITYIO_PHP_SDC_CLASSIFICATION_RES_NAME "SENSITIVITYIO_PHP_SDC_CLASSIFICATION"

Functions

PHP_FUNCTION (sensitivityio_php_sdc_classification_is_verification)
boolean sensitivityio_sdc_classification_is_verification(sensitivityio_php_sdc_classification_t $classification, boolean &$result); More...
PHP_FUNCTION (sensitivityio_php_sdc_classification_is_correct)
boolean sensitivityio_sdc_classification_is_correct(sensitivityio_php_sdc_classification_t $classification, boolean &$result); More...
PHP_FUNCTION (sensitivityio_php_sdc_classification_is_corporate)
boolean sensitivityio_sdc_classification_is_corporate(sensitivityio_php_sdc_classification_t $classification, boolean &$result); More...
PHP_FUNCTION (sensitivityio_php_sdc_classification_to_string)
string sensitivityio_sdc_classification_to_string(sensitivityio_php_sdc_classification_t $classification); More...

Variables

int le_sensitivityio_php_sdc_classification

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file classification.h.

Macro Definition Documentation

◆ SENSITIVITYIO_PHP_SDC_CLASSIFICATION_RES_NAME

#define SENSITIVITYIO_PHP_SDC_CLASSIFICATION_RES_NAME "SENSITIVITYIO_PHP_SDC_CLASSIFICATION"

Definition at line 19 of file classification.h.

Function Documentation

◆ PHP_FUNCTION() [1/4]

PHP_FUNCTION ( sensitivityio_php_sdc_classification_is_verification )

boolean sensitivityio_sdc_classification_is_verification(sensitivityio_php_sdc_classification_t $classification, boolean &$result);

◆ PHP_FUNCTION() [2/4]

PHP_FUNCTION ( sensitivityio_php_sdc_classification_is_correct )

boolean sensitivityio_sdc_classification_is_correct(sensitivityio_php_sdc_classification_t $classification, boolean &$result);

Precondition
sensitivityio_php_sdc_classification_is_verification()

◆ PHP_FUNCTION() [3/4]

PHP_FUNCTION ( sensitivityio_php_sdc_classification_is_corporate )

boolean sensitivityio_sdc_classification_is_corporate(sensitivityio_php_sdc_classification_t $classification, boolean &$result);

◆ PHP_FUNCTION() [4/4]

PHP_FUNCTION ( sensitivityio_php_sdc_classification_to_string )

string sensitivityio_sdc_classification_to_string(sensitivityio_php_sdc_classification_t $classification);

Variable Documentation

◆ le_sensitivityio_php_sdc_classification

int le_sensitivityio_php_sdc_classification


sensitivityio: sensitivityio/php_sdc/classifier.h File Reference

  • php_sdc
Macros | Functions | Variables
classifier.h File Reference
#include "config.h"
#include "classification.h"

Go to the source code of this file.

Macros

#define SENSITIVITYIO_PHP_SDC_CLASSIFIER_RES_NAME "SENSITIVITYIO_PHP_SDC_CLASSIFIER"

Functions

PHP_FUNCTION (sensitivityio_php_sdc_classifier_create)
sensitivityio_php_sdc_classifier_t sensitivityio_php_sdc_classifier_create(); More...
PHP_FUNCTION (sensitivityio_php_sdc_classifier_classify_string)
sensitivityio_php_sdc_classification_t sensitivityio_php_sdc_classifier_classify_string( sensitivityio_php_sdc_classifier_t $classifier, string $str); More...
PHP_FUNCTION (sensitivityio_php_sdc_classifier_classify_buffer)
sensitivityio_php_sdc_classification_t sensitivityio_php_sdc_classifier_classify_buffer( sensitivityio_php_sdc_classifier_t $classifier, string $buffer, string $fileName); More...
PHP_FUNCTION (sensitivityio_php_sdc_classifier_classify_file)
sensitivityio_php_sdc_classification_t sensitivityio_php_sdc_classifier_classify_file( sensitivityio_php_sdc_classifier_t $classifier, string $fileName); More...

Variables

int le_sensitivityio_php_sdc_classifier

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file classifier.h.

Macro Definition Documentation

◆ SENSITIVITYIO_PHP_SDC_CLASSIFIER_RES_NAME

#define SENSITIVITYIO_PHP_SDC_CLASSIFIER_RES_NAME "SENSITIVITYIO_PHP_SDC_CLASSIFIER"

Definition at line 20 of file classifier.h.

Function Documentation

◆ PHP_FUNCTION() [1/4]

PHP_FUNCTION ( sensitivityio_php_sdc_classifier_create )

sensitivityio_php_sdc_classifier_t sensitivityio_php_sdc_classifier_create();

◆ PHP_FUNCTION() [2/4]

PHP_FUNCTION ( sensitivityio_php_sdc_classifier_classify_string )

sensitivityio_php_sdc_classification_t sensitivityio_php_sdc_classifier_classify_string( sensitivityio_php_sdc_classifier_t $classifier, string $str);

Remarks
Relevant errno: SENSITIVITYIO_EINVALIDLICENSE, SENSITIVITYIO_ELICENSEEXPIRED, SENSITIVITYIO_ESETTINGS, SENSITIVITYIO_ENOKNOWNDATA, ECANCELED, EIO

◆ PHP_FUNCTION() [3/4]

PHP_FUNCTION ( sensitivityio_php_sdc_classifier_classify_buffer )

sensitivityio_php_sdc_classification_t sensitivityio_php_sdc_classifier_classify_buffer( sensitivityio_php_sdc_classifier_t $classifier, string $buffer, string $fileName);

Parameters
fileName If buffer is the content of a file, pass file name (it may be empty string)
Remarks
Relevant errno: SENSITIVITYIO_EINVALIDLICENSE, SENSITIVITYIO_ELICENSEEXPIRED, SENSITIVITYIO_ESETTINGS, SENSITIVITYIO_EUNSUPPORTEDMIMETYPE, SENSITIVITYIO_ENOKNOWNDATA, ECANCELED, EIO

◆ PHP_FUNCTION() [4/4]

PHP_FUNCTION ( sensitivityio_php_sdc_classifier_classify_file )

sensitivityio_php_sdc_classification_t sensitivityio_php_sdc_classifier_classify_file( sensitivityio_php_sdc_classifier_t $classifier, string $fileName);

Remarks
Relevant errno: SENSITIVITYIO_EINVALIDLICENSE, SENSITIVITYIO_ELICENSEEXPIRED, SENSITIVITYIO_ESETTINGS, SENSITIVITYIO_EUNSUPPORTEDMIMETYPE, SENSITIVITYIO_ENOKNOWNDATA, ECANCELED, ENOENT, EIO

Variable Documentation

◆ le_sensitivityio_php_sdc_classifier

int le_sensitivityio_php_sdc_classifier


sensitivityio: sensitivityio/php_sdc/classifier_settings_loader.h File Reference

  • php_sdc
Functions
classifier_settings_loader.h File Reference
#include "config.h"
#include <sensitivityio/php_license/settings_loader.h>
#include "classifier.h"

Go to the source code of this file.

Functions

PHP_FUNCTION (sensitivityio_php_sdc_classifier_settings_loader_create)
sensitivityio_php_settings_loader_t sensitivityio_php_sdc_classifier_settings_loader_create(void); More...
PHP_FUNCTION (sensitivityio_php_sdc_classifier_settings_loader_is_classifier_registered)
boolean sensitivityio_php_sdc_classifier_settings_loader_is_classifier_registered( sensitivityio_php_settings_loader_t $settingsLoader, sensitivityio_php_sdc_classifier_t $classifier, boolean &$result); More...
PHP_FUNCTION (sensitivityio_php_sdc_classifier_settings_loader_register_classifier)
boolean sensitivityio_php_sdc_classifier_settings_loader_register_classifier( sensitivityio_php_settings_loader_t $settingsLoader, sensitivityio_php_sdc_classifier_t $classifier); More...
PHP_FUNCTION (sensitivityio_php_sdc_classifier_settings_loader_unregister_classifier)
boolean sensitivityio_php_sdc_classifier_settings_loader_unregister_classifier( sensitivityio_php_settings_loader_t $settingsLoader, sensitivityio_php_sdc_classifier_t $classifier); More...

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file classifier_settings_loader.h.

Function Documentation

◆ PHP_FUNCTION() [1/4]

PHP_FUNCTION ( sensitivityio_php_sdc_classifier_settings_loader_create )

sensitivityio_php_settings_loader_t sensitivityio_php_sdc_classifier_settings_loader_create(void);

◆ PHP_FUNCTION() [2/4]

PHP_FUNCTION ( sensitivityio_php_sdc_classifier_settings_loader_is_classifier_registered )

boolean sensitivityio_php_sdc_classifier_settings_loader_is_classifier_registered( sensitivityio_php_settings_loader_t $settingsLoader, sensitivityio_php_sdc_classifier_t $classifier, boolean &$result);

◆ PHP_FUNCTION() [3/4]

PHP_FUNCTION ( sensitivityio_php_sdc_classifier_settings_loader_register_classifier )

boolean sensitivityio_php_sdc_classifier_settings_loader_register_classifier( sensitivityio_php_settings_loader_t $settingsLoader, sensitivityio_php_sdc_classifier_t $classifier);

Precondition
$classifier is not registered

◆ PHP_FUNCTION() [4/4]

PHP_FUNCTION ( sensitivityio_php_sdc_classifier_settings_loader_unregister_classifier )

boolean sensitivityio_php_sdc_classifier_settings_loader_unregister_classifier( sensitivityio_php_settings_loader_t $settingsLoader, sensitivityio_php_sdc_classifier_t $classifier);

Precondition
$classifier is registered


sensitivityio: sensitivityio/php_sdc/classifier_settings_retriever.h File Reference

  • php_sdc
Functions
classifier_settings_retriever.h File Reference
#include "config.h"
#include "classifier_settings_loader.h"
#include <sensitivityio/php_license/settings_retriever.h>

Go to the source code of this file.

Functions

PHP_FUNCTION (sensitivityio_php_sdc_classifier_settings_retriever_create)
sensitivityio_php_http_retriever_t sensitivityio_php_sdc_classifier_settings_retriever_create(); More...

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file classifier_settings_retriever.h.

Function Documentation

◆ PHP_FUNCTION()

PHP_FUNCTION ( sensitivityio_php_sdc_classifier_settings_retriever_create )

sensitivityio_php_http_retriever_t sensitivityio_php_sdc_classifier_settings_retriever_create();


sensitivityio: sensitivityio/php_sdc/config.h File Reference

  • php_sdc
Macros
config.h File Reference
#include <sensitivityio/php_license/config.h>
#include <php.h>
#include <zend_modules.h>

Go to the source code of this file.

Macros

#define | SENSITIVITYIO_PHP_SDC_API
#define | SENSITIVITYIO_PHP_SDC_VERSION SENSITIVITYIO_VERSION_STRING
#define | phpext_sensitivityio_php_sdc_ptr &sensitivityio_php_sdc_module_entry
#define | SENSITIVITYIO_PHP_SDC_G(v) (sensitivityio_php_sdc_globals.v)

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file config.h.

Macro Definition Documentation

◆ phpext_sensitivityio_php_sdc_ptr

#define phpext_sensitivityio_php_sdc_ptr &sensitivityio_php_sdc_module_entry

Definition at line 36 of file config.h.

◆ SENSITIVITYIO_PHP_SDC_API

#define SENSITIVITYIO_PHP_SDC_API

Definition at line 30 of file config.h.

◆ SENSITIVITYIO_PHP_SDC_G

#define SENSITIVITYIO_PHP_SDC_G ( v ) (sensitivityio_php_sdc_globals.v)

Definition at line 50 of file config.h.

◆ SENSITIVITYIO_PHP_SDC_VERSION

#define SENSITIVITYIO_PHP_SDC_VERSION SENSITIVITYIO_VERSION_STRING

Definition at line 34 of file config.h.


sensitivityio: sensitivityio/php_sdc/php_sdc.h File Reference

  • php_sdc
Functions | Variables
php_sdc.h File Reference
#include "config.h"

Go to the source code of this file.

Functions

PHP_MINIT_FUNCTION (sensitivityio_php_sdc)
PHP_MSHUTDOWN_FUNCTION (sensitivityio_php_sdc)
PHP_RINIT_FUNCTION (sensitivityio_php_sdc)
PHP_RSHUTDOWN_FUNCTION (sensitivityio_php_sdc)
PHP_MINFO_FUNCTION (sensitivityio_php_sdc)

Variables

zend_module_entry sensitivityio_php_sdc_module_entry

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file php_sdc.h.

Function Documentation

◆ PHP_MINFO_FUNCTION()

PHP_MINFO_FUNCTION ( sensitivityio_php_sdc )

◆ PHP_MINIT_FUNCTION()

PHP_MINIT_FUNCTION ( sensitivityio_php_sdc )

◆ PHP_MSHUTDOWN_FUNCTION()

PHP_MSHUTDOWN_FUNCTION ( sensitivityio_php_sdc )

◆ PHP_RINIT_FUNCTION()

PHP_RINIT_FUNCTION ( sensitivityio_php_sdc )

◆ PHP_RSHUTDOWN_FUNCTION()

PHP_RSHUTDOWN_FUNCTION ( sensitivityio_php_sdc )

Variable Documentation

◆ sensitivityio_php_sdc_module_entry

zend_module_entry sensitivityio_php_sdc_module_entry


sensitivityio: sensitivityio/php_sds Directory Reference

  • php_sds
php_sds Directory Reference

Files

file | config.h [code]
file | php_sds.h [code]
file | scanner.h [code]
file | scanner_settings_loader.h [code]
file | scanner_settings_retriever.h [code]
file | sds_threat_type.h [code]
file | threat_info.h [code]
file | threat_infos.h [code]
file | threat_location.h [code]


sensitivityio: sensitivityio/php_sds/config.h File Reference

  • php_sds
Macros
config.h File Reference
#include <sensitivityio/php_license/config.h>
#include <php.h>
#include <zend_modules.h>

Go to the source code of this file.

Macros

#define | SENSITIVITYIO_PHP_SDS_API
#define | SENSITIVITYIO_PHP_SDS_VERSION SENSITIVITYIO_VERSION_STRING
#define | phpext_sensitivityio_php_sds_ptr &sensitivityio_php_sds_module_entry
#define | SENSITIVITYIO_PHP_SDS_G(v) (sensitivityio_php_sds_globals.v)

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file config.h.

Macro Definition Documentation

◆ phpext_sensitivityio_php_sds_ptr

#define phpext_sensitivityio_php_sds_ptr &sensitivityio_php_sds_module_entry

Definition at line 36 of file config.h.

◆ SENSITIVITYIO_PHP_SDS_API

#define SENSITIVITYIO_PHP_SDS_API

Definition at line 30 of file config.h.

◆ SENSITIVITYIO_PHP_SDS_G

#define SENSITIVITYIO_PHP_SDS_G ( v ) (sensitivityio_php_sds_globals.v)

Definition at line 50 of file config.h.

◆ SENSITIVITYIO_PHP_SDS_VERSION

#define SENSITIVITYIO_PHP_SDS_VERSION SENSITIVITYIO_VERSION_STRING

Definition at line 34 of file config.h.


sensitivityio: sensitivityio/php_sds/php_sds.h File Reference

  • php_sds
Functions | Variables
php_sds.h File Reference
#include "config.h"

Go to the source code of this file.

Functions

PHP_MINIT_FUNCTION (sensitivityio_php_sds)
PHP_MSHUTDOWN_FUNCTION (sensitivityio_php_sds)
PHP_RINIT_FUNCTION (sensitivityio_php_sds)
PHP_RSHUTDOWN_FUNCTION (sensitivityio_php_sds)
PHP_MINFO_FUNCTION (sensitivityio_php_sds)

Variables

zend_module_entry sensitivityio_php_sds_module_entry

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file php_sds.h.

Function Documentation

◆ PHP_MINFO_FUNCTION()

PHP_MINFO_FUNCTION ( sensitivityio_php_sds )

◆ PHP_MINIT_FUNCTION()

PHP_MINIT_FUNCTION ( sensitivityio_php_sds )

◆ PHP_MSHUTDOWN_FUNCTION()

PHP_MSHUTDOWN_FUNCTION ( sensitivityio_php_sds )

◆ PHP_RINIT_FUNCTION()

PHP_RINIT_FUNCTION ( sensitivityio_php_sds )

◆ PHP_RSHUTDOWN_FUNCTION()

PHP_RSHUTDOWN_FUNCTION ( sensitivityio_php_sds )

Variable Documentation

◆ sensitivityio_php_sds_module_entry

zend_module_entry sensitivityio_php_sds_module_entry


sensitivityio: sensitivityio/php_sds/scanner.h File Reference

  • php_sds
Macros | Functions | Variables
scanner.h File Reference
#include "config.h"
#include "threat_info.h"
#include "threat_infos.h"

Go to the source code of this file.

Macros

#define SENSITIVITYIO_PHP_SDS_SCANNER_RES_NAME "SENSITIVITYIO_PHP_SDS_SCANNER"

Functions

PHP_FUNCTION (sensitivityio_php_sds_scanner_create)
sensitivityio_php_sds_scanner_t sensitivityio_php_sds_scanner_create(); More...
PHP_FUNCTION (sensitivityio_php_sds_scanner_scan_string_th)
boolean sensitivityio_php_sds_scanner_scan_string_th(sensitivityio_php_sds_scanner_t $scanner, string $str, string $threatHandlerFunctionName, void* pThreatHandlerData); More...
PHP_FUNCTION (sensitivityio_php_sds_scanner_scan_buffer_th)
boolean sensitivityio_php_sds_scanner_scan_buffer_th(sensitivityio_php_sds_scanner_t $scanner, string $buffer, string $threatHandlerFunctionName, void* pThreatHandlerData, string $fileName); More...
PHP_FUNCTION (sensitivityio_php_sds_scanner_scan_file_th)
boolean sensitivityio_php_sds_scanner_scan_file_th(sensitivityio_php_sds_scanner_t $scanner, string $fileName, string $threatHandlerFunctionName, void* pThreatHandlerData); More...
PHP_FUNCTION (sensitivityio_php_sds_scanner_scan_string)
sensitivityio_php_sds_threat_infos_t sensitivityio_php_sds_scanner_scan_string( sensitivityio_php_sds_scanner_t $scanner, string $str, boolean $stopAtFirstThreat); More...
PHP_FUNCTION (sensitivityio_php_sds_scanner_scan_buffer)
sensitivityio_php_sds_threat_infos_t sensitivityio_php_sds_scanner_scan_buffer( sensitivityio_php_sds_scanner_t $scanner, string $buffer, boolean $stopAtFirstThreat, string $fileName); More...
PHP_FUNCTION (sensitivityio_php_sds_scanner_scan_file)
sensitivityio_php_sds_threat_infos_t sensitivityio_php_sds_scanner_scan_file( sensitivityio_php_sds_scanner_t $scanner, string $fileName, boolean $stopAtFirstThreat); More...

Variables

int le_sensitivityio_php_sds_scanner

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file scanner.h.

Macro Definition Documentation

◆ SENSITIVITYIO_PHP_SDS_SCANNER_RES_NAME

#define SENSITIVITYIO_PHP_SDS_SCANNER_RES_NAME "SENSITIVITYIO_PHP_SDS_SCANNER"

Definition at line 21 of file scanner.h.

Function Documentation

◆ PHP_FUNCTION() [1/7]

PHP_FUNCTION ( sensitivityio_php_sds_scanner_create )

sensitivityio_php_sds_scanner_t sensitivityio_php_sds_scanner_create();

◆ PHP_FUNCTION() [2/7]

PHP_FUNCTION ( sensitivityio_php_sds_scanner_scan_string_th )

boolean sensitivityio_php_sds_scanner_scan_string_th(sensitivityio_php_sds_scanner_t $scanner, string $str, string $threatHandlerFunctionName, void* pThreatHandlerData);

Remarks
Relevant errno: SENSITIVITYIO_EINVALIDLICENSE, SENSITIVITYIO_ELICENSEEXPIRED, SENSITIVITYIO_ESETTINGS, ECANCELED, EIO

◆ PHP_FUNCTION() [3/7]

PHP_FUNCTION ( sensitivityio_php_sds_scanner_scan_buffer_th )

boolean sensitivityio_php_sds_scanner_scan_buffer_th(sensitivityio_php_sds_scanner_t $scanner, string $buffer, string $threatHandlerFunctionName, void* pThreatHandlerData, string $fileName);

Parameters
fileName If buffer is the content of a file, pass file name (it may be empty string)
Remarks
Relevant errno: SENSITIVITYIO_EINVALIDLICENSE, SENSITIVITYIO_ELICENSEEXPIRED, SENSITIVITYIO_ESETTINGS, SENSITIVITYIO_EUNSUPPORTEDMIMETYPE, ECANCELED, EIO

◆ PHP_FUNCTION() [4/7]

PHP_FUNCTION ( sensitivityio_php_sds_scanner_scan_file_th )

boolean sensitivityio_php_sds_scanner_scan_file_th(sensitivityio_php_sds_scanner_t $scanner, string $fileName, string $threatHandlerFunctionName, void* pThreatHandlerData);

Remarks
Relevant errno: SENSITIVITYIO_EINVALIDLICENSE, SENSITIVITYIO_ELICENSEEXPIRED, SENSITIVITYIO_ESETTINGS, SENSITIVITYIO_EUNSUPPORTEDMIMETYPE, ECANCELED, ENOENT, EIO

◆ PHP_FUNCTION() [5/7]

PHP_FUNCTION ( sensitivityio_php_sds_scanner_scan_string )

sensitivityio_php_sds_threat_infos_t sensitivityio_php_sds_scanner_scan_string( sensitivityio_php_sds_scanner_t $scanner, string $str, boolean $stopAtFirstThreat);

Remarks
Relevant errno: SENSITIVITYIO_EINVALIDLICENSE, SENSITIVITYIO_ELICENSEEXPIRED, SENSITIVITYIO_ESETTINGS, ECANCELED, EIO

◆ PHP_FUNCTION() [6/7]

PHP_FUNCTION ( sensitivityio_php_sds_scanner_scan_buffer )

sensitivityio_php_sds_threat_infos_t sensitivityio_php_sds_scanner_scan_buffer( sensitivityio_php_sds_scanner_t $scanner, string $buffer, boolean $stopAtFirstThreat, string $fileName);

Parameters
fileName If buffer is the content of a file, pass file name (it may be empty string)
Remarks
Relevant errno: SENSITIVITYIO_EINVALIDLICENSE, SENSITIVITYIO_ELICENSEEXPIRED, SENSITIVITYIO_ESETTINGS, SENSITIVITYIO_EUNSUPPORTEDMIMETYPE, ECANCELED, EIO

◆ PHP_FUNCTION() [7/7]

PHP_FUNCTION ( sensitivityio_php_sds_scanner_scan_file )

sensitivityio_php_sds_threat_infos_t sensitivityio_php_sds_scanner_scan_file( sensitivityio_php_sds_scanner_t $scanner, string $fileName, boolean $stopAtFirstThreat);

Remarks
Relevant errno: SENSITIVITYIO_EINVALIDLICENSE, SENSITIVITYIO_ELICENSEEXPIRED, SENSITIVITYIO_ESETTINGS, SENSITIVITYIO_EUNSUPPORTEDMIMETYPE, ECANCELED, ENOENT, EIO

Variable Documentation

◆ le_sensitivityio_php_sds_scanner

int le_sensitivityio_php_sds_scanner


sensitivityio: sensitivityio/php_sds/scanner_settings_loader.h File Reference

  • php_sds
Functions
scanner_settings_loader.h File Reference
#include "config.h"
#include <sensitivityio/php_license/settings_loader.h>
#include "scanner.h"

Go to the source code of this file.

Functions

PHP_FUNCTION (sensitivityio_php_sds_scanner_settings_loader_create)
sensitivityio_php_settings_loader_t sensitivityio_php_sds_scanner_settings_loader_create(void); More...
PHP_FUNCTION (sensitivityio_php_sds_scanner_settings_loader_is_scanner_registered)
boolean sensitivityio_php_sds_scanner_settings_loader_is_scanner_registered( sensitivityio_php_settings_loader_t $settingsLoader, sensitivityio_php_sds_scanner_t $scanner, boolean &$result); More...
PHP_FUNCTION (sensitivityio_php_sds_scanner_settings_loader_register_scanner)
boolean sensitivityio_php_sds_scanner_settings_loader_register_scanner( sensitivityio_php_settings_loader_t $settingsLoader, sensitivityio_php_sds_scanner_t $scanner); More...
PHP_FUNCTION (sensitivityio_php_sds_scanner_settings_loader_unregister_scanner)
boolean sensitivityio_php_sds_scanner_settings_loader_unregister_scanner( sensitivityio_php_settings_loader_t $settingsLoader, sensitivityio_php_sds_scanner_t $scanner); More...

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file scanner_settings_loader.h.

Function Documentation

◆ PHP_FUNCTION() [1/4]

PHP_FUNCTION ( sensitivityio_php_sds_scanner_settings_loader_create )

sensitivityio_php_settings_loader_t sensitivityio_php_sds_scanner_settings_loader_create(void);

◆ PHP_FUNCTION() [2/4]

PHP_FUNCTION ( sensitivityio_php_sds_scanner_settings_loader_is_scanner_registered )

boolean sensitivityio_php_sds_scanner_settings_loader_is_scanner_registered( sensitivityio_php_settings_loader_t $settingsLoader, sensitivityio_php_sds_scanner_t $scanner, boolean &$result);

◆ PHP_FUNCTION() [3/4]

PHP_FUNCTION ( sensitivityio_php_sds_scanner_settings_loader_register_scanner )

boolean sensitivityio_php_sds_scanner_settings_loader_register_scanner( sensitivityio_php_settings_loader_t $settingsLoader, sensitivityio_php_sds_scanner_t $scanner);

Precondition
$canner is not registered

◆ PHP_FUNCTION() [4/4]

PHP_FUNCTION ( sensitivityio_php_sds_scanner_settings_loader_unregister_scanner )

boolean sensitivityio_php_sds_scanner_settings_loader_unregister_scanner( sensitivityio_php_settings_loader_t $settingsLoader, sensitivityio_php_sds_scanner_t $scanner);

Precondition
$canner is registered


sensitivityio: sensitivityio/php_sds/scanner_settings_retriever.h File Reference

  • php_sds
Functions
scanner_settings_retriever.h File Reference
#include "config.h"
#include "scanner_settings_loader.h"
#include <sensitivityio/php_license/settings_retriever.h>

Go to the source code of this file.

Functions

PHP_FUNCTION (sensitivityio_php_sds_scanner_settings_retriever_create)
sensitivityio_php_http_retriever_t sensitivityio_php_sds_scanner_settings_retriever_create(); More...

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file scanner_settings_retriever.h.

Function Documentation

◆ PHP_FUNCTION()

PHP_FUNCTION ( sensitivityio_php_sds_scanner_settings_retriever_create )

sensitivityio_php_http_retriever_t sensitivityio_php_sds_scanner_settings_retriever_create();


sensitivityio: sensitivityio/php_sds/sds_threat_type.h File Reference

  • php_sds
Functions
sds_threat_type.h File Reference
#include "config.h"

Go to the source code of this file.

Functions

PHP_FUNCTION (sensitivityio_php_sds_get_threat_type_name)
string sensitivityio_php_sds_get_threat_type_name(sensitivityio_sds_threat_type_id_t $threatTypeId); More...

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file sds_threat_type.h.

Function Documentation

◆ PHP_FUNCTION()

PHP_FUNCTION ( sensitivityio_php_sds_get_threat_type_name )

string sensitivityio_php_sds_get_threat_type_name(sensitivityio_sds_threat_type_id_t $threatTypeId);


sensitivityio: sensitivityio/php_sds/threat_info.h File Reference

  • php_sds
Macros | Functions | Variables
threat_info.h File Reference
#include "config.h"
#include "threat_location.h"

Go to the source code of this file.

Macros

#define SENSITIVITYIO_PHP_SDS_THREAT_INFO_RES_NAME "SENSITIVITYIO_PHP_SDS_THREAT_INFO"

Functions

PHP_FUNCTION (sensitivityio_php_sds_threat_info_set_threat_type_id)
boolean sensitivityio_php_sds_threat_info_set_threat_type_id(sensitivityio_php_sds_threat_info_t $threatInfo, integer $threatTypeId); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_info_get_threat_type_id)
boolean sensitivityio_php_sds_threat_info_get_threat_type_id(sensitivityio_php_sds_threat_info_t $threatInfo, integer &$result); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_info_set_matched_text)
boolean sensitivityio_php_sds_threat_info_set_matched_text(sensitivityio_php_sds_threat_info_t $threatInfo, string $matchedText); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_info_get_matched_text)
string sensitivityio_php_sds_threat_info_get_matched_text(sensitivityio_php_sds_threat_info_t $threatInfo); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_info_get_masked_matched_text)
string sensitivityio_php_sds_threat_info_get_masked_matched_text(sensitivityio_php_sds_threat_info_t $threatInfo); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_info_set_threat_description)
boolean sensitivityio_php_sds_threat_info_set_threat_description(sensitivityio_php_sds_threat_info_t $threatInfo, string $threatDescription); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_info_get_threat_description)
string sensitivityio_php_sds_threat_info_get_threat_description(sensitivityio_php_sds_threat_info_t $threatInfo); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_info_set_threat_location)
boolean sensitivityio_php_sds_threat_info_set_threat_location(sensitivityio_php_sds_threat_info_t $threatInfo, sensitivityio_php_sds_threat_location_t $threatLocation); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_info_get_threat_location)
sensitivityio_php_sds_threat_location_t sensitivityio_php_sds_threat_info_get_threat_location( sensitivityio_php_sds_threat_info_t $threatInfo); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_info_to_string)
string sensitivityio_php_sds_threat_info_to_string(sensitivityio_php_sds_threat_info_t $threatInfo); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_info_to_masked_string)
string sensitivityio_php_sds_threat_info_to_masked_string(sensitivityio_php_sds_threat_info_t $threatInfo); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_info_st_get_masked_matched_text)
string sensitivityio_php_sds_threat_info_st_get_masked_matched_text(string $plainMatchedText, integer $threatTypeId); More...

Variables

int le_sensitivityio_php_sds_threat_info

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file threat_info.h.

Macro Definition Documentation

◆ SENSITIVITYIO_PHP_SDS_THREAT_INFO_RES_NAME

#define SENSITIVITYIO_PHP_SDS_THREAT_INFO_RES_NAME "SENSITIVITYIO_PHP_SDS_THREAT_INFO"

Definition at line 20 of file threat_info.h.

Function Documentation

◆ PHP_FUNCTION() [1/12]

PHP_FUNCTION ( sensitivityio_php_sds_threat_info_set_threat_type_id )

boolean sensitivityio_php_sds_threat_info_set_threat_type_id(sensitivityio_php_sds_threat_info_t $threatInfo, integer $threatTypeId);

◆ PHP_FUNCTION() [2/12]

PHP_FUNCTION ( sensitivityio_php_sds_threat_info_get_threat_type_id )

boolean sensitivityio_php_sds_threat_info_get_threat_type_id(sensitivityio_php_sds_threat_info_t $threatInfo, integer &$result);

◆ PHP_FUNCTION() [3/12]

PHP_FUNCTION ( sensitivityio_php_sds_threat_info_set_matched_text )

boolean sensitivityio_php_sds_threat_info_set_matched_text(sensitivityio_php_sds_threat_info_t $threatInfo, string $matchedText);

◆ PHP_FUNCTION() [4/12]

PHP_FUNCTION ( sensitivityio_php_sds_threat_info_get_matched_text )

string sensitivityio_php_sds_threat_info_get_matched_text(sensitivityio_php_sds_threat_info_t $threatInfo);

◆ PHP_FUNCTION() [5/12]

PHP_FUNCTION ( sensitivityio_php_sds_threat_info_get_masked_matched_text )

string sensitivityio_php_sds_threat_info_get_masked_matched_text(sensitivityio_php_sds_threat_info_t $threatInfo);

◆ PHP_FUNCTION() [6/12]

PHP_FUNCTION ( sensitivityio_php_sds_threat_info_set_threat_description )

boolean sensitivityio_php_sds_threat_info_set_threat_description(sensitivityio_php_sds_threat_info_t $threatInfo, string $threatDescription);

◆ PHP_FUNCTION() [7/12]

PHP_FUNCTION ( sensitivityio_php_sds_threat_info_get_threat_description )

string sensitivityio_php_sds_threat_info_get_threat_description(sensitivityio_php_sds_threat_info_t $threatInfo);

◆ PHP_FUNCTION() [8/12]

PHP_FUNCTION ( sensitivityio_php_sds_threat_info_set_threat_location )

boolean sensitivityio_php_sds_threat_info_set_threat_location(sensitivityio_php_sds_threat_info_t $threatInfo, sensitivityio_php_sds_threat_location_t $threatLocation);

◆ PHP_FUNCTION() [9/12]

PHP_FUNCTION ( sensitivityio_php_sds_threat_info_get_threat_location )

sensitivityio_php_sds_threat_location_t sensitivityio_php_sds_threat_info_get_threat_location( sensitivityio_php_sds_threat_info_t $threatInfo);

◆ PHP_FUNCTION() [10/12]

PHP_FUNCTION ( sensitivityio_php_sds_threat_info_to_string )

string sensitivityio_php_sds_threat_info_to_string(sensitivityio_php_sds_threat_info_t $threatInfo);

◆ PHP_FUNCTION() [11/12]

PHP_FUNCTION ( sensitivityio_php_sds_threat_info_to_masked_string )

string sensitivityio_php_sds_threat_info_to_masked_string(sensitivityio_php_sds_threat_info_t $threatInfo);

◆ PHP_FUNCTION() [12/12]

PHP_FUNCTION ( sensitivityio_php_sds_threat_info_st_get_masked_matched_text )

string sensitivityio_php_sds_threat_info_st_get_masked_matched_text(string $plainMatchedText, integer $threatTypeId);

Variable Documentation

◆ le_sensitivityio_php_sds_threat_info

int le_sensitivityio_php_sds_threat_info


sensitivityio: sensitivityio/php_sds/threat_infos.h File Reference

  • php_sds
Macros | Functions | Variables
threat_infos.h File Reference
#include "config.h"
#include "threat_info.h"

Go to the source code of this file.

Macros

#define SENSITIVITYIO_PHP_SDS_THREAT_INFOS_RES_NAME "SENSITIVITYIO_PHP_SDS_THREAT_INFOS"

Functions

PHP_FUNCTION (sensitivityio_php_sds_threat_infos_get_size)
boolean sensitivityio_php_sds_threat_infos_get_size(sensitivityio_php_sds_threat_infos_t $threatInfos, integer &$result); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_infos_get_element)
sensitivityio_php_sds_threat_info_t sensitivityio_php_sds_threat_infos_get_element( sensitivityio_php_sds_threat_infos_t $threatInfos, integer $index); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_infos_append_element)
boolean sensitivityio_php_sds_threat_infos_append_element(sensitivityio_php_sds_threat_infos_t $threatInfos, sensitivityio_php_sds_threat_info_t $threatInfo); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_infos_clear)
boolean sensitivityio_php_sds_threat_infos_clear(sensitivityio_php_sds_threat_infos_t $threatInfos); More...

Variables

int le_sensitivityio_php_sds_threat_infos

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file threat_infos.h.

Macro Definition Documentation

◆ SENSITIVITYIO_PHP_SDS_THREAT_INFOS_RES_NAME

#define SENSITIVITYIO_PHP_SDS_THREAT_INFOS_RES_NAME "SENSITIVITYIO_PHP_SDS_THREAT_INFOS"

Definition at line 20 of file threat_infos.h.

Function Documentation

◆ PHP_FUNCTION() [1/4]

PHP_FUNCTION ( sensitivityio_php_sds_threat_infos_get_size )

boolean sensitivityio_php_sds_threat_infos_get_size(sensitivityio_php_sds_threat_infos_t $threatInfos, integer &$result);

◆ PHP_FUNCTION() [2/4]

PHP_FUNCTION ( sensitivityio_php_sds_threat_infos_get_element )

sensitivityio_php_sds_threat_info_t sensitivityio_php_sds_threat_infos_get_element( sensitivityio_php_sds_threat_infos_t $threatInfos, integer $index);

◆ PHP_FUNCTION() [3/4]

PHP_FUNCTION ( sensitivityio_php_sds_threat_infos_append_element )

boolean sensitivityio_php_sds_threat_infos_append_element(sensitivityio_php_sds_threat_infos_t $threatInfos, sensitivityio_php_sds_threat_info_t $threatInfo);

◆ PHP_FUNCTION() [4/4]

PHP_FUNCTION ( sensitivityio_php_sds_threat_infos_clear )

boolean sensitivityio_php_sds_threat_infos_clear(sensitivityio_php_sds_threat_infos_t $threatInfos);

Variable Documentation

◆ le_sensitivityio_php_sds_threat_infos

int le_sensitivityio_php_sds_threat_infos


sensitivityio: sensitivityio/php_sds/threat_location.h File Reference

  • php_sds
Macros | Functions | Variables
threat_location.h File Reference
#include "config.h"

Go to the source code of this file.

Macros

#define SENSITIVITYIO_PHP_SDS_THREAT_LOCATION_RES_NAME "SENSITIVITYIO_PHP_SDS_THREAT_LOCATION"

Functions

PHP_FUNCTION (sensitivityio_php_sds_threat_location_set_file_name)
boolean sensitivityio_php_sds_threat_location_set_file_name( sensitivityio_php_sds_threat_location_t $threatLocation, string $fileName); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_location_get_file_name)
string sensitivityio_php_sds_threat_location_get_file_name( sensitivityio_php_sds_threat_location_t $threatLocation); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_location_set_archive_member)
boolean sensitivityio_php_sds_threat_location_set_archive_member( sensitivityio_php_sds_threat_location_t $threatLocation, string $archiveMember); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_location_get_archive_member)
string sensitivityio_php_sds_threat_location_get_archive_member( sensitivityio_php_sds_threat_location_t $threatLocation); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_location_set_offset)
boolean sensitivityio_php_sds_threat_location_set_offset( sensitivityio_php_sds_threat_location_t $threatLocation, integer $offset); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_location_get_offset)
boolean sensitivityio_php_sds_threat_location_get_offset( sensitivityio_php_sds_threat_location_t $threatLocation, integer &$result); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_location_set_line_number)
boolean sensitivityio_php_sds_threat_location_set_line_number( sensitivityio_php_sds_threat_location_t $threatLocation, integer $lineNumber); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_location_get_line_number)
boolean sensitivityio_php_sds_threat_location_get_line_number( sensitivityio_php_sds_threat_location_t $threatLocation, integer &$result); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_location_set_surrounding_text)
boolean sensitivityio_php_sds_threat_location_set_surrounding_text( sensitivityio_php_sds_threat_location_t $threatLocation, string $surroundingText); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_location_get_surrounding_text)
string sensitivityio_php_sds_threat_location_get_surrounding_text( sensitivityio_php_sds_threat_location_t $threatLocation); More...
PHP_FUNCTION (sensitivityio_php_sds_threat_location_to_string)
string sensitivityio_php_sds_threat_location_to_string( sensitivityio_php_sds_threat_location_t $threatLocation); More...

Variables

int le_sensitivityio_php_sds_threat_location

Detailed Description

Copyright
Copyright (C) 2017 CoSoSys Ltd team@.nosp@m.sens.nosp@m.itivi.nosp@m.ty.i.nosp@m.o
CoSoSys Ltd. All rights reserved.
Please see the file COPYING for more details.
Authors
Cristian ANITA crist.nosp@m.ian..nosp@m.anita.nosp@m.@cos.nosp@m.osys..nosp@m.com

Definition in file threat_location.h.

Macro Definition Documentation

◆ SENSITIVITYIO_PHP_SDS_THREAT_LOCATION_RES_NAME

#define SENSITIVITYIO_PHP_SDS_THREAT_LOCATION_RES_NAME "SENSITIVITYIO_PHP_SDS_THREAT_LOCATION"

Definition at line 19 of file threat_location.h.

Function Documentation

◆ PHP_FUNCTION() [1/11]

PHP_FUNCTION ( sensitivityio_php_sds_threat_location_set_file_name )

boolean sensitivityio_php_sds_threat_location_set_file_name( sensitivityio_php_sds_threat_location_t $threatLocation, string $fileName);

◆ PHP_FUNCTION() [2/11]

PHP_FUNCTION ( sensitivityio_php_sds_threat_location_get_file_name )

string sensitivityio_php_sds_threat_location_get_file_name( sensitivityio_php_sds_threat_location_t $threatLocation);

◆ PHP_FUNCTION() [3/11]

PHP_FUNCTION ( sensitivityio_php_sds_threat_location_set_archive_member )

boolean sensitivityio_php_sds_threat_location_set_archive_member( sensitivityio_php_sds_threat_location_t $threatLocation, string $archiveMember);

◆ PHP_FUNCTION() [4/11]

PHP_FUNCTION ( sensitivityio_php_sds_threat_location_get_archive_member )

string sensitivityio_php_sds_threat_location_get_archive_member( sensitivityio_php_sds_threat_location_t $threatLocation);

◆ PHP_FUNCTION() [5/11]

PHP_FUNCTION ( sensitivityio_php_sds_threat_location_set_offset )

boolean sensitivityio_php_sds_threat_location_set_offset( sensitivityio_php_sds_threat_location_t $threatLocation, integer $offset);

◆ PHP_FUNCTION() [6/11]

PHP_FUNCTION ( sensitivityio_php_sds_threat_location_get_offset )

boolean sensitivityio_php_sds_threat_location_get_offset( sensitivityio_php_sds_threat_location_t $threatLocation, integer &$result);

◆ PHP_FUNCTION() [7/11]

PHP_FUNCTION ( sensitivityio_php_sds_threat_location_set_line_number )

boolean sensitivityio_php_sds_threat_location_set_line_number( sensitivityio_php_sds_threat_location_t $threatLocation, integer $lineNumber);

◆ PHP_FUNCTION() [8/11]

PHP_FUNCTION ( sensitivityio_php_sds_threat_location_get_line_number )

boolean sensitivityio_php_sds_threat_location_get_line_number( sensitivityio_php_sds_threat_location_t $threatLocation, integer &$result);

◆ PHP_FUNCTION() [9/11]

PHP_FUNCTION ( sensitivityio_php_sds_threat_location_set_surrounding_text )

boolean sensitivityio_php_sds_threat_location_set_surrounding_text( sensitivityio_php_sds_threat_location_t $threatLocation, string $surroundingText);

◆ PHP_FUNCTION() [10/11]

PHP_FUNCTION ( sensitivityio_php_sds_threat_location_get_surrounding_text )

string sensitivityio_php_sds_threat_location_get_surrounding_text( sensitivityio_php_sds_threat_location_t $threatLocation);

◆ PHP_FUNCTION() [11/11]

PHP_FUNCTION ( sensitivityio_php_sds_threat_location_to_string )

string sensitivityio_php_sds_threat_location_to_string( sensitivityio_php_sds_threat_location_t $threatLocation);

Variable Documentation

◆ le_sensitivityio_php_sds_threat_location

int le_sensitivityio_php_sds_threat_location


sensitivityio: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- c -

  • CURL_AT_LEAST_VERSION : third_party.hpp
  • CURL_VERSION_BITS : third_party.hpp

- l -

  • le_sensitivityio_php_http_retriever : http_retriever.h
  • le_sensitivityio_php_license_loader : license_loader.h
  • le_sensitivityio_php_sdc_classification : classification.h
  • le_sensitivityio_php_sdc_classifier : classifier.h
  • le_sensitivityio_php_sds_scanner : scanner.h
  • le_sensitivityio_php_sds_threat_info : threat_info.h
  • le_sensitivityio_php_sds_threat_infos : threat_infos.h
  • le_sensitivityio_php_sds_threat_location : threat_location.h
  • le_sensitivityio_php_settings_loader : settings_loader.h

- p -

  • PHP_FE_END : config.h
  • PHP_FUNCTION() : application_id_retriever.h , threat_info.h , scanner.h , http_retriever.h , threat_infos.h , threat_location.h , settings_retriever.h , classifier_settings_loader.h , settings_retriever.h , http_retriever.h , classifier_settings_retriever.h , threat_location.h , http_retriever.h , settings_loader.h , threat_infos.h , http_retriever.h , version.h , errno.h , threat_location.h , scanner_settings_retriever.h , http_retriever.h , settings_retriever.h , application_id_retriever.h , scanner_settings_loader.h , http_retriever.h , license_loader.h , scanner_settings_loader.h , license_loader.h , license_retriever.h , threat_info.h , license_loader.h , http_retriever.h , classifier.h , scanner.h , classification.h , threat_location.h , classifier.h , threat_location.h , classifier.h , http_retriever.h , license_retriever.h , classification.h , http_retriever.h , scanner_settings_loader.h , scanner.h , license_retriever.h , version.h , http_retriever.h , threat_location.h , threat_info.h , version.h , classification.h , http_retriever.h , scanner.h , threat_location.h , sds_threat_type.h , settings_loader.h , scanner.h , threat_infos.h , errno.h , http_retriever.h , threat_location.h , threat_infos.h , http_retriever.h , scanner_settings_loader.h , version.h , threat_location.h , version.h , threat_location.h , classifier_settings_loader.h , scanner.h , classifier.h , classifier_settings_loader.h , scanner.h , classifier_settings_loader.h , threat_location.h , http_retriever.h
  • PHP_MINFO_FUNCTION() : php_base.h , php_license.h , php_sds.h , php_sdc.h
  • PHP_MINIT_FUNCTION() : php_base.h , php_license.h , php_sds.h , php_sdc.h
  • PHP_MSHUTDOWN_FUNCTION() : php_license.h , php_sds.h , php_base.h , php_sdc.h
  • PHP_RINIT_FUNCTION() : php_base.h , php_license.h , php_sds.h , php_sdc.h
  • PHP_RSHUTDOWN_FUNCTION() : php_base.h , php_license.h , php_sds.h , php_sdc.h
  • phpext_sensitivityio_php_base_ptr : config.h
  • phpext_sensitivityio_php_license_ptr : config.h
  • phpext_sensitivityio_php_sdc_ptr : config.h
  • phpext_sensitivityio_php_sds_ptr : config.h

- s -

  • SENSITIVITYIO_COPYRIGHT : product_info.hpp
  • SENSITIVITYIO_DESCRIPTION : product_info.hpp
  • SENSITIVITYIO_DISABLE_SENSITIVITYIO_WARNINGS : features.hpp
  • SENSITIVITYIO_DISABLE_THIRD_PARTY_WARNINGS : features.hpp
  • SENSITIVITYIO_EMAIL : product_info.hpp
  • SENSITIVITYIO_ESTORE : product_info.hpp
  • SENSITIVITYIO_FORCE_DBC_IN_CLIENT_API : features.hpp
  • SENSITIVITYIO_HAVE_APACHE_TIKA : third_party.hpp
  • SENSITIVITYIO_HAVE_CHARDET : third_party.hpp
  • SENSITIVITYIO_HAVE_CURL : third_party.hpp
  • SENSITIVITYIO_HOMEPAGE : product_info.hpp
  • SENSITIVITYIO_LONG_NAME : product_info.hpp
  • SENSITIVITYIO_LONG_NAME_SANITIZED : product_info.hpp
  • SENSITIVITYIO_ONLINE_REGISTRATION : product_info.hpp
  • SENSITIVITYIO_ONLINE_SUPPORT : product_info.hpp
  • SENSITIVITYIO_PHP_BASE_API : config.h
  • SENSITIVITYIO_PHP_BASE_G : config.h
  • sensitivityio_php_base_module_entry : php_base.h
  • SENSITIVITYIO_PHP_BASE_VERSION : config.h
  • SENSITIVITYIO_PHP_HTTP_RETRIEVER_RES_NAME : http_retriever.h
  • SENSITIVITYIO_PHP_LICENSE_API : config.h
  • SENSITIVITYIO_PHP_LICENSE_G : config.h
  • SENSITIVITYIO_PHP_LICENSE_LOADER_RES_NAME : license_loader.h
  • sensitivityio_php_license_module_entry : php_license.h
  • SENSITIVITYIO_PHP_LICENSE_VERSION : config.h
  • SENSITIVITYIO_PHP_SDC_API : config.h
  • SENSITIVITYIO_PHP_SDC_CLASSIFICATION_RES_NAME : classification.h
  • SENSITIVITYIO_PHP_SDC_CLASSIFIER_RES_NAME : classifier.h
  • SENSITIVITYIO_PHP_SDC_G : config.h
  • sensitivityio_php_sdc_module_entry : php_sdc.h
  • SENSITIVITYIO_PHP_SDC_VERSION : config.h
  • SENSITIVITYIO_PHP_SDS_API : config.h
  • SENSITIVITYIO_PHP_SDS_G : config.h
  • sensitivityio_php_sds_module_entry : php_sds.h
  • SENSITIVITYIO_PHP_SDS_SCANNER_RES_NAME : scanner.h
  • SENSITIVITYIO_PHP_SDS_THREAT_INFO_RES_NAME : threat_info.h
  • SENSITIVITYIO_PHP_SDS_THREAT_INFOS_RES_NAME : threat_infos.h
  • SENSITIVITYIO_PHP_SDS_THREAT_LOCATION_RES_NAME : threat_location.h
  • SENSITIVITYIO_PHP_SDS_VERSION : config.h
  • SENSITIVITYIO_PHP_SETTINGS_LOADER_RES_NAME : settings_loader.h
  • SENSITIVITYIO_SHORT_NAME : product_info.hpp
  • SENSITIVITYIO_SHORT_NAME_SANITIZED : product_info.hpp
  • SENSITIVITYIO_TRADEMARKS : product_info.hpp
  • SENSITIVITYIO_VERSION_MAJOR : product_info.hpp
  • SENSITIVITYIO_VERSION_MINOR : product_info.hpp
  • SENSITIVITYIO_VERSION_NUMBER : product_info.hpp
  • SENSITIVITYIO_VERSION_PATCH : product_info.hpp
  • SENSITIVITYIO_VERSION_STRING : product_info.hpp


sensitivityio: Globals

- p -

  • PHP_FUNCTION() : application_id_retriever.h , errno.h , http_retriever.h , license_retriever.h , threat_infos.h , settings_loader.h , threat_infos.h , threat_location.h , http_retriever.h , settings_loader.h , threat_location.h , settings_retriever.h , threat_location.h , http_retriever.h , settings_retriever.h , classifier_settings_retriever.h , classifier_settings_loader.h , classifier.h , classification.h , threat_location.h , settings_retriever.h , threat_location.h , http_retriever.h , scanner.h , http_retriever.h , scanner.h , threat_infos.h , threat_info.h , sds_threat_type.h , scanner_settings_retriever.h , scanner_settings_loader.h , scanner.h , http_retriever.h , scanner.h , http_retriever.h , version.h , errno.h , http_retriever.h , version.h , license_retriever.h , license_loader.h , http_retriever.h , version.h , license_loader.h , http_retriever.h
  • PHP_MINFO_FUNCTION() : php_license.h , php_sds.h , php_base.h , php_sdc.h
  • PHP_MINIT_FUNCTION() : php_license.h , php_sds.h , php_base.h , php_sdc.h
  • PHP_MSHUTDOWN_FUNCTION() : php_sdc.h , php_base.h , php_license.h , php_sds.h
  • PHP_RINIT_FUNCTION() : php_sdc.h , php_base.h , php_license.h , php_sds.h
  • PHP_RSHUTDOWN_FUNCTION() : php_sdc.h , php_sds.h , php_base.h , php_license.h


sensitivityio: Globals

  • le_sensitivityio_php_http_retriever : http_retriever.h
  • le_sensitivityio_php_license_loader : license_loader.h
  • le_sensitivityio_php_sdc_classification : classification.h
  • le_sensitivityio_php_sdc_classifier : classifier.h
  • le_sensitivityio_php_sds_scanner : scanner.h
  • le_sensitivityio_php_sds_threat_info : threat_info.h
  • le_sensitivityio_php_sds_threat_infos : threat_infos.h
  • le_sensitivityio_php_sds_threat_location : threat_location.h
  • le_sensitivityio_php_settings_loader : settings_loader.h
  • sensitivityio_php_base_module_entry : php_base.h
  • sensitivityio_php_license_module_entry : php_license.h
  • sensitivityio_php_sdc_module_entry : php_sdc.h
  • sensitivityio_php_sds_module_entry : php_sds.h


sensitivityio: Globals

- c -

  • CURL_AT_LEAST_VERSION : third_party.hpp
  • CURL_VERSION_BITS : third_party.hpp

- p -

  • PHP_FE_END : config.h
  • phpext_sensitivityio_php_base_ptr : config.h
  • phpext_sensitivityio_php_license_ptr : config.h
  • phpext_sensitivityio_php_sdc_ptr : config.h
  • phpext_sensitivityio_php_sds_ptr : config.h

- s -

  • SENSITIVITYIO_COPYRIGHT : product_info.hpp
  • SENSITIVITYIO_DESCRIPTION : product_info.hpp
  • SENSITIVITYIO_DISABLE_SENSITIVITYIO_WARNINGS : features.hpp
  • SENSITIVITYIO_DISABLE_THIRD_PARTY_WARNINGS : features.hpp
  • SENSITIVITYIO_EMAIL : product_info.hpp
  • SENSITIVITYIO_ESTORE : product_info.hpp
  • SENSITIVITYIO_FORCE_DBC_IN_CLIENT_API : features.hpp
  • SENSITIVITYIO_HAVE_APACHE_TIKA : third_party.hpp
  • SENSITIVITYIO_HAVE_CHARDET : third_party.hpp
  • SENSITIVITYIO_HAVE_CURL : third_party.hpp
  • SENSITIVITYIO_HOMEPAGE : product_info.hpp
  • SENSITIVITYIO_LONG_NAME : product_info.hpp
  • SENSITIVITYIO_LONG_NAME_SANITIZED : product_info.hpp
  • SENSITIVITYIO_ONLINE_REGISTRATION : product_info.hpp
  • SENSITIVITYIO_ONLINE_SUPPORT : product_info.hpp
  • SENSITIVITYIO_PHP_BASE_API : config.h
  • SENSITIVITYIO_PHP_BASE_G : config.h
  • SENSITIVITYIO_PHP_BASE_VERSION : config.h
  • SENSITIVITYIO_PHP_HTTP_RETRIEVER_RES_NAME : http_retriever.h
  • SENSITIVITYIO_PHP_LICENSE_API : config.h
  • SENSITIVITYIO_PHP_LICENSE_G : config.h
  • SENSITIVITYIO_PHP_LICENSE_LOADER_RES_NAME : license_loader.h
  • SENSITIVITYIO_PHP_LICENSE_VERSION : config.h
  • SENSITIVITYIO_PHP_SDC_API : config.h
  • SENSITIVITYIO_PHP_SDC_CLASSIFICATION_RES_NAME : classification.h
  • SENSITIVITYIO_PHP_SDC_CLASSIFIER_RES_NAME : classifier.h
  • SENSITIVITYIO_PHP_SDC_G : config.h
  • SENSITIVITYIO_PHP_SDC_VERSION : config.h
  • SENSITIVITYIO_PHP_SDS_API : config.h
  • SENSITIVITYIO_PHP_SDS_G : config.h
  • SENSITIVITYIO_PHP_SDS_SCANNER_RES_NAME : scanner.h
  • SENSITIVITYIO_PHP_SDS_THREAT_INFO_RES_NAME : threat_info.h
  • SENSITIVITYIO_PHP_SDS_THREAT_INFOS_RES_NAME : threat_infos.h
  • SENSITIVITYIO_PHP_SDS_THREAT_LOCATION_RES_NAME : threat_location.h
  • SENSITIVITYIO_PHP_SDS_VERSION : config.h
  • SENSITIVITYIO_PHP_SETTINGS_LOADER_RES_NAME : settings_loader.h
  • SENSITIVITYIO_SHORT_NAME : product_info.hpp
  • SENSITIVITYIO_SHORT_NAME_SANITIZED : product_info.hpp
  • SENSITIVITYIO_TRADEMARKS : product_info.hpp
  • SENSITIVITYIO_VERSION_MAJOR : product_info.hpp
  • SENSITIVITYIO_VERSION_MINOR : product_info.hpp
  • SENSITIVITYIO_VERSION_NUMBER : product_info.hpp
  • SENSITIVITYIO_VERSION_PATCH : product_info.hpp
  • SENSITIVITYIO_VERSION_STRING : product_info.hpp


sensitivityio: sensitivityio/php_base/application_id_retriever.h Source File

  • php_base
application_id_retriever.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_BASE_APPLICATION_ID_RETRIEVER_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_BASE_APPLICATION_ID_RETRIEVER_H_INCLUDED_
14
15
16 #include "config.h"
17 #include "http_retriever.h"
18
19
20 #ifdef __cplusplus
21 extern "C" {
22 #endif
23
24
26 PHP_FUNCTION(sensitivityio_php_application_id_retriever_get_instance);
27
30 PHP_FUNCTION(sensitivityio_php_application_id_retriever_retrieve_application_id);
31
32
33 #ifdef __cplusplus
34 }
35 #endif
36
37
38 #endif // SENSITIVITYIO_PHP_BASE_APPLICATION_ID_RETRIEVER_H_INCLUDED_
PHP_FUNCTION
PHP_FUNCTION(sensitivityio_php_application_id_retriever_get_instance)
sensitivityio_php_http_retriever_t sensitivityio_php_application_id_retriever_get_instance(); ...
http_retriever.h
config.h


sensitivityio: sensitivityio/config/compiler/clang.hpp Source File

  • config
  • compiler
clang.hpp
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_CONFIG_COMPILER_HPP_INCLUDED_
13 # error "Do not include directly; please include <sensitivityio/config/compiler.hpp> instead!!!"
14 #endif
15
16
17 #ifndef SENSITIVITYIO_CONFIG_COMPILER_CLANG_HPP_INCLUDED_
18 #define SENSITIVITYIO_CONFIG_COMPILER_CLANG_HPP_INCLUDED_
19
20
21 #ifdef NDEBUG
22 # if (FORTIFY_SOURCE != 2)
23 # ifdef SENSITIVITYIO_DETAIL_BUILD
24 # undef FORTIFY_SOURCE
25 # define FORTIFY_SOURCE 2
26 # endif
27 # endif
28 #endif
29
30
31 #include <cppdevtk/config/compiler.hpp>
32 #if (!CPPDEVTK_COMPILER_CLANG)
33 # error "This file is Clang specific!!!"
34 #endif
35
36
38 // Third party warnings.
39 #if (SENSITIVITYIO_DISABLE_THIRD_PARTY_WARNINGS)
40 //# pragma GCC diagnostic ignored "-Wdeprecated-declarations"
41 // TODO: put other third-party warnings safe to disable here.
42 #endif
43
44
46 // sensitivityio warnings.
47 #if (SENSITIVITYIO_DISABLE_SENSITIVITYIO_WARNINGS)
48 //# pragma GCC diagnostic ignored "-Wunused-local-typedefs"
49 // TODO: put other sensitivityio warnings safe to disable here.
50 #endif
51
52
54 // Compiler Features.
55 // TODO: test for compiler features here.
56
57
58 #endif // SENSITIVITYIO_CONFIG_COMPILER_CLANG_HPP_INCLUDED_


sensitivityio: sensitivityio/php_sdc/classification.h Source File

  • php_sdc
classification.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_SENSITIVE_DATA_CLASSIFICATION_CLASSIFICATION_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_SENSITIVE_DATA_CLASSIFICATION_CLASSIFICATION_H_INCLUDED_
14
15
16 #include "config.h"
17
18
19 #define SENSITIVITYIO_PHP_SDC_CLASSIFICATION_RES_NAME "SENSITIVITYIO_PHP_SDC_CLASSIFICATION"
20
21
22 #ifdef __cplusplus
23 extern "C" {
24 #endif
25
26
29 PHP_FUNCTION(sensitivityio_php_sdc_classification_is_verification);
30
34 PHP_FUNCTION(sensitivityio_php_sdc_classification_is_correct);
35
38 PHP_FUNCTION(sensitivityio_php_sdc_classification_is_corporate);
39
41 PHP_FUNCTION(sensitivityio_php_sdc_classification_to_string);
42
43
44 extern int le_sensitivityio_php_sdc_classification;
45
46
47 #ifdef __cplusplus
48 }
49 #endif
50
51
52 #endif // SENSITIVITYIO_PHP_SENSITIVE_DATA_CLASSIFICATION_CLASSIFICATION_H_INCLUDED_
config.h
le_sensitivityio_php_sdc_classification
int le_sensitivityio_php_sdc_classification
PHP_FUNCTION
PHP_FUNCTION(sensitivityio_php_sdc_classification_is_verification)
boolean sensitivityio_sdc_classification_is_verification(sensitivityio_php_sdc_classification_t $clas...


sensitivityio: sensitivityio/php_sdc/classifier.h Source File

  • php_sdc
classifier.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_SENSITIVE_DATA_CLASSIFICATION_CLASSIFIER_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_SENSITIVE_DATA_CLASSIFICATION_CLASSIFIER_H_INCLUDED_
14
15
16 #include "config.h"
17 #include "classification.h"
18
19
20 #define SENSITIVITYIO_PHP_SDC_CLASSIFIER_RES_NAME "SENSITIVITYIO_PHP_SDC_CLASSIFIER"
21
22
23 #ifdef __cplusplus
24 extern "C" {
25 #endif
26
27
29 PHP_FUNCTION(sensitivityio_php_sdc_classifier_create);
30
35 PHP_FUNCTION(sensitivityio_php_sdc_classifier_classify_string);
36
42 PHP_FUNCTION(sensitivityio_php_sdc_classifier_classify_buffer);
43
48 PHP_FUNCTION(sensitivityio_php_sdc_classifier_classify_file);
49
50
51 extern int le_sensitivityio_php_sdc_classifier;
52
53
54 #ifdef __cplusplus
55 }
56 #endif
57
58
59 #endif // SENSITIVITYIO_PHP_SENSITIVE_DATA_CLASSIFICATION_CLASSIFIER_H_INCLUDED_
classification.h
le_sensitivityio_php_sdc_classifier
int le_sensitivityio_php_sdc_classifier
PHP_FUNCTION
PHP_FUNCTION(sensitivityio_php_sdc_classifier_create)
sensitivityio_php_sdc_classifier_t sensitivityio_php_sdc_classifier_create();
config.h


sensitivityio: sensitivityio/php_sdc/classifier_settings_loader.h Source File

  • php_sdc
classifier_settings_loader.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_SENSITIVE_DATA_CLASSIFICATION_CLASSIFIER_SETTINGS_LOADER_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_SENSITIVE_DATA_CLASSIFICATION_CLASSIFIER_SETTINGS_LOADER_H_INCLUDED_
14
15
16 #include "config.h"
17 #include <sensitivityio/php_license/settings_loader.h>
18 #include "classifier.h"
19
20
21 #ifdef __cplusplus
22 extern "C" {
23 #endif
24
25
27 PHP_FUNCTION(sensitivityio_php_sdc_classifier_settings_loader_create);
28
29
32 PHP_FUNCTION(sensitivityio_php_sdc_classifier_settings_loader_is_classifier_registered);
33
37 PHP_FUNCTION(sensitivityio_php_sdc_classifier_settings_loader_register_classifier);
38
42 PHP_FUNCTION(sensitivityio_php_sdc_classifier_settings_loader_unregister_classifier);
43
44
45 #ifdef __cplusplus
46 }
47 #endif
48
49
50 #endif // SENSITIVITYIO_PHP_SENSITIVE_DATA_CLASSIFICATION_CLASSIFIER_SETTINGS_LOADER_H_INCLUDED_
config.h
classifier.h
settings_loader.h
PHP_FUNCTION
PHP_FUNCTION(sensitivityio_php_sdc_classifier_settings_loader_create)
sensitivityio_php_settings_loader_t sensitivityio_php_sdc_classifier_settings_loader_create(void); ...


sensitivityio: sensitivityio/php_sdc/classifier_settings_retriever.h Source File

  • php_sdc
classifier_settings_retriever.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_SENSITIVE_DATA_CLASSIFICATION_CLASSIFIER_SETTINGS_RETRIEVER_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_SENSITIVE_DATA_CLASSIFICATION_CLASSIFIER_SETTINGS_RETRIEVER_H_INCLUDED_
14
15
16 #include "config.h"
17 #include "classifier_settings_loader.h"
18 #include <sensitivityio/php_license/settings_retriever.h>
19
20
21 #ifdef __cplusplus
22 extern "C" {
23 #endif
24
25
27 PHP_FUNCTION(sensitivityio_php_sdc_classifier_settings_retriever_create);
28
29
30 #ifdef __cplusplus
31 }
32 #endif
33
34
35 #endif // SENSITIVITYIO_PHP_SENSITIVE_DATA_CLASSIFICATION_CLASSIFIER_SETTINGS_RETRIEVER_H_INCLUDED_
config.h
settings_retriever.h
PHP_FUNCTION
PHP_FUNCTION(sensitivityio_php_sdc_classifier_settings_retriever_create)
sensitivityio_php_http_retriever_t sensitivityio_php_sdc_classifier_settings_retriever_create(); ...
classifier_settings_loader.h


sensitivityio: sensitivityio/config/compiler.hpp Source File

  • config
compiler.hpp
Go to the documentation of this file.
1
11
12 #ifdef APSTUDIO_INVOKED
13 # error "This file is not editable by Microsoft Visual C++!!!"
14 #endif
15
16
17 #ifndef SENSITIVITYIO_CONFIG_COMPILER_HPP_INCLUDED_
18 #define SENSITIVITYIO_CONFIG_COMPILER_HPP_INCLUDED_
19
20
21 #include "features.hpp"
22
23
24 #ifndef RC_INVOKED
25
26 #if (defined(__GNUC__) && !defined(__clang__))
27 # include "compiler/gcc.hpp"
28 #elif (defined(__clang__))
29 # include "compiler/clang.hpp"
30 #elif (defined(_MSC_VER))
31 # include "compiler/msvc.hpp"
32 #else
33 # error "Unsupported compiler!!!"
34 #endif
35
36 #endif // !RC_INVOKED
37
38
39 #include <cppdevtk/config/compiler.hpp>
40
41
42 #endif // SENSITIVITYIO_CONFIG_COMPILER_HPP_INCLUDED_
clang.hpp
features.hpp
gcc.hpp
msvc.hpp


sensitivityio: sensitivityio/config/config.hpp Source File

  • config
config.hpp
Go to the documentation of this file.
1
11
12 #ifdef APSTUDIO_INVOKED
13 # error "This file is not editable by Microsoft Visual C++!!!"
14 #endif
15
16
17 #ifndef SENSITIVITYIO_CONFIG_CONFIG_HPP_INCLUDED_
18 #define SENSITIVITYIO_CONFIG_CONFIG_HPP_INCLUDED_
19
20
21 #include "features.hpp"
22 #include "product_info.hpp"
23 #include "info.hpp"
24 #include "compiler.hpp"
25 #include "platform.hpp"
26 #include "platform_compiler.hpp"
27 #include "third_party.hpp"
28
29
30 #include <cppdevtk/util/config.hpp>
31
32
33 #endif // SENSITIVITYIO_CONFIG_CONFIG_HPP_INCLUDED_
platform.hpp
info.hpp
compiler.hpp
platform_compiler.hpp
features.hpp
third_party.hpp
product_info.hpp


sensitivityio: sensitivityio/php_base/errno.h Source File

  • php_base
errno.h
Go to the documentation of this file.
1
23
24 #ifndef SENSITIVITYIO_PHP_BASE_ERRNO_H_INCLUDED_
25 #define SENSITIVITYIO_PHP_BASE_ERRNO_H_INCLUDED_
26
27
28 #include "config.h"
29
30
31 #ifdef __cplusplus
32 extern "C" {
33 #endif
34
35
37 PHP_FUNCTION(sensitivityio_php_get_errno);
38
40 PHP_FUNCTION(sensitivityio_php_get_errmsg);
41
42
43 #ifdef __cplusplus
44 }
45 #endif
46
47
48 #endif // SENSITIVITYIO_PHP_BASE_ERRNO_H_INCLUDED_
PHP_FUNCTION
PHP_FUNCTION(sensitivityio_php_get_errno)
integer sensitivityio_php_get_errno();
config.h


sensitivityio: sensitivityio/config/features.hpp Source File

  • config
features.hpp
Go to the documentation of this file.
1
11
12 #ifdef APSTUDIO_INVOKED
13 # error "This file is not editable by Microsoft Visual C++!!!"
14 #endif
15
16
17 #ifndef SENSITIVITYIO_CONFIG_FEATURES_HPP_INCLUDED_
18 #define SENSITIVITYIO_CONFIG_FEATURES_HPP_INCLUDED_
19
20
22 // sensitivityio features
23
24 #ifndef SENSITIVITYIO_DISABLE_THIRD_PARTY_WARNINGS
25 # ifdef SENSITIVITYIO_DETAIL_BUILD
26 # define SENSITIVITYIO_DISABLE_THIRD_PARTY_WARNINGS 1
27 # else
28 # define SENSITIVITYIO_DISABLE_THIRD_PARTY_WARNINGS 0
29 # endif
30 #endif
31
32 #ifndef SENSITIVITYIO_DISABLE_SENSITIVITYIO_WARNINGS
33 # ifdef SENSITIVITYIO_DETAIL_BUILD
34 # define SENSITIVITYIO_DISABLE_SENSITIVITYIO_WARNINGS 1
35 # else
36 # define SENSITIVITYIO_DISABLE_SENSITIVITYIO_WARNINGS 0
37 # endif
38 #endif
39
40 #ifndef SENSITIVITYIO_FORCE_DBC_IN_CLIENT_API
41 # define SENSITIVITYIO_FORCE_DBC_IN_CLIENT_API 1
42 #endif
43
44
46 // CppDevTk features
47
48 #ifdef SENSITIVITYIO_DETAIL_BUILD
49
50 #ifndef CPPDEVTK_ENABLE_PLATFORM_VERSION
51 # define CPPDEVTK_ENABLE_PLATFORM_VERSION 1
52 #endif
53
54 #ifndef RC_INVOKED // for RC4011 identifier truncated
55
56 #ifndef CPPDEVTK_DISABLE_THIRD_PARTY_WARNINGS
57 # if (SENSITIVITYIO_DISABLE_THIRD_PARTY_WARNINGS)
58 # define CPPDEVTK_DISABLE_THIRD_PARTY_WARNINGS 1
59 # else
60 # define CPPDEVTK_DISABLE_THIRD_PARTY_WARNINGS 0
61 # endif
62 #endif
63
64 #ifndef CPPDEVTK_DISABLE_CPPDEVTK_WARNINGS
65 # if (SENSITIVITYIO_DISABLE_THIRD_PARTY_WARNINGS)
66 # define CPPDEVTK_DISABLE_CPPDEVTK_WARNINGS 1
67 # else
68 # define CPPDEVTK_DISABLE_CPPDEVTK_WARNINGS 0
69 # endif
70 #endif
71
72 #endif // RC_INVOKED
73
74 #ifndef CPPDEVTK_DISABLE_QT_OUTPUT
75 # ifdef NDEBUG
76 # define CPPDEVTK_DISABLE_QT_OUTPUT 1
77 # else
78 # define CPPDEVTK_DISABLE_QT_OUTPUT 0
79 # endif
80 #endif
81
82 #ifndef CPPDEVTK_ENABLE_LOG
83 # ifdef NDEBUG
84 # define CPPDEVTK_ENABLE_LOG 0
85 # else
86 # define CPPDEVTK_ENABLE_LOG 1
87 # endif
88 #endif
89
90 #ifndef CPPDEVTK_LOG_LEVEL
91 # define CPPDEVTK_LOG_LEVEL ::cppdevtk::base::llDebug
92 #endif
93
94 #ifndef CPPDEVTK_LOGGER_DATE_FORMAT
95 # define CPPDEVTK_LOGGER_DATE_FORMAT "yyyy-MMM-dd hh:mm:ss:zzz"
96 #endif
97
98 #ifndef CPPDEVTK_ENABLE_DBC
99 # ifdef NDEBUG
100 # define CPPDEVTK_ENABLE_DBC 0
101 # else
102 # define CPPDEVTK_ENABLE_DBC 1
103 # endif
104 #endif
105
106 #ifndef CPPDEVTK_DBC_DISABLE_THROW_ON_FAILURE
107 # define CPPDEVTK_DBC_DISABLE_THROW_ON_FAILURE 0
108 #endif
109
110 #ifndef CPPDEVTK_DBC_DISABLE_CHECK_PRECONDITION
111 # define CPPDEVTK_DBC_DISABLE_CHECK_PRECONDITION 0
112 #endif
113
114 #ifndef CPPDEVTK_DBC_DISABLE_CHECK_POSTCONDITION
115 # define CPPDEVTK_DBC_DISABLE_CHECK_POSTCONDITION 0
116 #endif
117
118 #ifndef CPPDEVTK_DBC_DISABLE_CHECK_INVARIANT
119 # define CPPDEVTK_DBC_DISABLE_CHECK_INVARIANT 0
120 #endif
121
122 #endif // SENSITIVITYIO_DETAIL_BUILD
123
124
125 #include <cppdevtk/config/features.hpp>
126
127
128 #endif // SENSITIVITYIO_CONFIG_FEATURES_HPP_INCLUDED_


sensitivityio: sensitivityio/config/compiler/gcc.hpp Source File

  • config
  • compiler
gcc.hpp
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_CONFIG_COMPILER_HPP_INCLUDED_
13 # error "Do not include directly; please include <sensitivityio/config/compiler.hpp> instead!!!"
14 #endif
15
16
17 #ifndef SENSITIVITYIO_CONFIG_COMPILER_GCC_HPP_INCLUDED_
18 #define SENSITIVITYIO_CONFIG_COMPILER_GCC_HPP_INCLUDED_
19
20
21 #ifdef NDEBUG
22 # if (FORTIFY_SOURCE != 2)
23 # ifdef SENSITIVITYIO_DETAIL_BUILD
24 # undef FORTIFY_SOURCE
25 # define FORTIFY_SOURCE 2
26 # endif
27 # endif
28 #endif
29
30
31 #include <cppdevtk/config/compiler.hpp>
32 #if (!CPPDEVTK_COMPILER_GCC)
33 # error "This file is GCC specific!!!"
34 #endif
35
36
37 #if (CPPDEVTK_GNUC_VERSION_NUM >= CPPDEVTK_GNUC_VERSION_NUM_FROM_COMPONENTS(4, 2, 0))
38
40 // Third party warnings.
41 #if (SENSITIVITYIO_DISABLE_THIRD_PARTY_WARNINGS)
42 //#pragma GCC diagnostic ignored "-Wunused-parameter"
43 // TODO: put other third-party warnings safe to disable here.
44 #endif
45
46
48 // sensitivityio warnings.
49 #if (SENSITIVITYIO_DISABLE_SENSITIVITYIO_WARNINGS)
50 //#pragma GCC diagnostic ignored "-Wdeprecated-declarations" // auto_ptr in C++11
51 // TODO: put other sensitivityio warnings safe to disable here.
52 #endif
53
54 #endif // Disable warnings (Diagnostic Pragmas, GCC >= 4.2)
55
56
58 // Compiler Features.
59 // TODO: test for compiler features here.
60
61
62 #endif // SENSITIVITYIO_CONFIG_COMPILER_GCC_HPP_INCLUDED_


sensitivityio: sensitivityio/php_base/http_retriever.h Source File

  • php_base
http_retriever.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_BASE_HTTP_RETRIEVER_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_BASE_HTTP_RETRIEVER_H_INCLUDED_
14
15
16 #include "config.h"
17
18
19 #define SENSITIVITYIO_PHP_HTTP_RETRIEVER_RES_NAME "SENSITIVITYIO_PHP_HTTP_RETRIEVER"
20
21
22 #ifdef __cplusplus
23 extern "C" {
24 #endif
25
26
28 PHP_FUNCTION(sensitivityio_php_http_retriever_get_host_name);
29
31 PHP_FUNCTION(sensitivityio_php_http_retriever_set_host_name);
32
34 PHP_FUNCTION(sensitivityio_php_http_retriever_get_api_ver);
35
37 PHP_FUNCTION(sensitivityio_php_http_retriever_set_api_ver);
38
40 PHP_FUNCTION(sensitivityio_php_http_retriever_get_account_id);
41
43 PHP_FUNCTION(sensitivityio_php_http_retriever_set_account_id);
44
46 PHP_FUNCTION(sensitivityio_php_http_retriever_get_project_id);
47
49 PHP_FUNCTION(sensitivityio_php_http_retriever_set_project_id);
50
52 PHP_FUNCTION(sensitivityio_php_http_retriever_get_authentication_key);
53
55 PHP_FUNCTION(sensitivityio_php_http_retriever_set_authentication_key);
56
58 PHP_FUNCTION(sensitivityio_php_http_retriever_get_application_id);
59
61 PHP_FUNCTION(sensitivityio_php_http_retriever_set_application_id);
62
64 PHP_FUNCTION(sensitivityio_php_http_retriever_get_destination_file);
65
68 PHP_FUNCTION(sensitivityio_php_http_retriever_set_destination_file);
69
71 PHP_FUNCTION(sensitivityio_php_http_retriever_get_url);
72
75 PHP_FUNCTION(sensitivityio_php_http_retriever_retrieve_to_string);
76
79 PHP_FUNCTION(sensitivityio_php_http_retriever_retrieve_to_file);
80
81
82 extern int le_sensitivityio_php_http_retriever;
83
84
85 #ifdef __cplusplus
86 }
87 #endif
88
89
90 #endif // SENSITIVITYIO_PHP_BASE_HTTP_RETRIEVER_H_INCLUDED_
PHP_FUNCTION
PHP_FUNCTION(sensitivityio_php_http_retriever_get_host_name)
string sensitivityio_php_http_retriever_get_host_name(); If not set, default is api.sensitivity.io
le_sensitivityio_php_http_retriever
int le_sensitivityio_php_http_retriever
config.h


sensitivityio: Main Page

sensitivityio Documentation


sensitivityio: sensitivityio/config/info.hpp Source File

  • config
info.hpp
Go to the documentation of this file.
1
11
12 #ifdef APSTUDIO_INVOKED
13 # error "This file is not editable by Microsoft Visual C++!!!"
14 #endif
15
16
17 #ifndef SENSITIVITYIO_CONFIG_INFO_HPP_INCLUDED_
18 #define SENSITIVITYIO_CONFIG_INFO_HPP_INCLUDED_
19
20
21 #include "features.hpp"
22 #include "product_info.hpp"
23
24 #include <cppdevtk/config/company_info.hpp>
25
26
27 #endif // SENSITIVITYIO_CONFIG_INFO_HPP_INCLUDED_
features.hpp
product_info.hpp


sensitivityio: sensitivityio/php_license/license_loader.h Source File

  • php_license
license_loader.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_LICENSE_LICENSE_LOADER_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_LICENSE_LICENSE_LOADER_H_INCLUDED_
14
15
16 #include "config.h"
17
18
19
20 #define SENSITIVITYIO_PHP_LICENSE_LOADER_RES_NAME "SENSITIVITYIO_PHP_LICENSE_LOADER"
21
22
23 #ifdef __cplusplus
24 extern "C" {
25 #endif
26
27
29 PHP_FUNCTION(sensitivityio_php_license_loader_get_instance);
30
33 PHP_FUNCTION(sensitivityio_php_license_loader_load_license_from_string);
34
37 PHP_FUNCTION(sensitivityio_php_license_loader_load_license_from_file);
38
39
40 extern int le_sensitivityio_php_license_loader;
41
42
43 #ifdef __cplusplus
44 }
45 #endif
46
47
48 #endif // SENSITIVITYIO_PHP_LICENSE_LICENSE_LOADER_H_INCLUDED_
PHP_FUNCTION
PHP_FUNCTION(sensitivityio_php_license_loader_get_instance)
sensitivityio_php_license_loader_t sensitivityio_php_license_loader_get_instance(); ...
le_sensitivityio_php_license_loader
int le_sensitivityio_php_license_loader
config.h


sensitivityio: sensitivityio/php_license/license_retriever.h Source File

  • php_license
license_retriever.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_LICENSE_LICENSE_RETRIEVER_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_LICENSE_LICENSE_RETRIEVER_H_INCLUDED_
14
15
16 #include "config.h"
17 #include "license_loader.h"
18 #include <sensitivityio/php_base/http_retriever.h>
19
20
21 #ifdef __cplusplus
22 extern "C" {
23 #endif
24
25
27 PHP_FUNCTION(sensitivityio_php_license_retriever_get_instance);
28
32 PHP_FUNCTION(sensitivityio_php_license_retriever_retrieve_to_string_and_notify_loader);
33
37 PHP_FUNCTION(sensitivityio_php_license_retriever_retrieve_to_file_and_notify_loader);
38
39
40 #ifdef __cplusplus
41 }
42 #endif
43
44
45 #endif // SENSITIVITYIO_PHP_LICENSE_LICENSE_RETRIEVER_H_INCLUDED_
PHP_FUNCTION
PHP_FUNCTION(sensitivityio_php_license_retriever_get_instance)
sensitivityio_php_http_retriever_t sensitivityio_php_license_retriever_get_instance(void); ...
license_loader.h
http_retriever.h
config.h


sensitivityio: sensitivityio/config/platform/linux.hpp Source File

  • config
  • platform
linux.hpp
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_CONFIG_PLATFORM_HPP_INCLUDED_
13 # error "Do not include directly; please include <sensitivityio/config/platform.hpp> instead!!!"
14 #endif
15
16
17 #ifndef SENSITIVITYIO_CONFIG_PLATFORM_LINUX_HPP_INCLUDED_
18 #define SENSITIVITYIO_CONFIG_PLATFORM_LINUX_HPP_INCLUDED_
19
20
21 #include "unix.hpp"
22
23 #include <cppdevtk/config/platform.hpp>
24 #if (!CPPDEVTK_PLATFORM_LINUX)
25 # error "This file is Linux specific!!!"
26 #endif
27
28
30 // Platform Features.
31 // TODO: test for platform features here
32
33
34 #endif // SENSITIVITYIO_CONFIG_PLATFORM_LINUX_HPP_INCLUDED_
unix.hpp


sensitivityio: sensitivityio/config/platform_compiler/linux_gcc.hpp Source File

  • config
  • platform_compiler
linux_gcc.hpp
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_HPP_INCLUDED_
13 # error "Do not include directly; please include <sensitivityio/config/platform_compiler.hpp> instead!!!"
14 #endif
15
16 #if (!CPPDEVTK_PLATFORM_LINUX)
17 # error "This file is Linux specific!!!"
18 #endif
19
20 #if (!CPPDEVTK_COMPILER_GCC)
21 # error "This file is GCC specific!!!"
22 #endif
23
24
25 #ifndef SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_LINUX_GCC_HPP_INCLUDED_
26 #define SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_LINUX_GCC_HPP_INCLUDED_
27
28
29 #include "unix_gcc.hpp"
30 #include <cppdevtk/config/platform_compiler.hpp>
31
32
34 // Platform Compiler Features.
35
36
37 #endif // SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_LINUX_GCC_HPP_INCLUDED_
unix_gcc.hpp


sensitivityio: sensitivityio/config/platform/macosx.hpp Source File

  • config
  • platform
macosx.hpp
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_CONFIG_PLATFORM_HPP_INCLUDED_
13 # error "Do not include directly; please include <sensitivityio/config/platform.hpp> instead!!!"
14 #endif
15
16
17 #ifndef SENSITIVITYIO_CONFIG_PLATFORM_MACOSX_HPP_INCLUDED_
18 #define SENSITIVITYIO_CONFIG_PLATFORM_MACOSX_HPP_INCLUDED_
19
20
21 #include "unix.hpp"
22
23 #include <cppdevtk/config/platform.hpp>
24 #if (!CPPDEVTK_PLATFORM_MACOSX)
25 # error "This file is Mac OS X specific!!!"
26 #endif
27
28
30 // Platform Features.
31 // TODO: test for platform features here
32
33
34 #endif // SENSITIVITYIO_CONFIG_PLATFORM_MACOSX_HPP_INCLUDED_
unix.hpp


sensitivityio: sensitivityio/config/platform_compiler/macosx_clang.hpp Source File

  • config
  • platform_compiler
macosx_clang.hpp
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_HPP_INCLUDED_
13 # error "Do not include directly; please include <sensitivityio/config/platform_compiler.hpp> instead!!!"
14 #endif
15
16 #if (!CPPDEVTK_PLATFORM_MACOSX)
17 # error "This file is Mac OS X specific!!!"
18 #endif
19
20 #if (!CPPDEVTK_COMPILER_CLANG)
21 # error "This file is Clang specific!!!"
22 #endif
23
24 #ifndef __apple_build_version__
25 # error "This file is Apple Clang specific!!!"
26 #endif
27
28
29 #ifndef SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_MACOSX_CLANG_HPP_INCLUDED_
30 #define SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_MACOSX_CLANG_HPP_INCLUDED_
31
32
33 #include "unix_clang.hpp"
34 #include <cppdevtk/config/platform_compiler.hpp>
35
36
38 // Platform Compiler Features.
39
40
41 #endif // SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_MACOSX_CLANG_HPP_INCLUDED_
unix_clang.hpp


sensitivityio: sensitivityio/config/platform_compiler/macosx_gcc.hpp Source File

  • config
  • platform_compiler
macosx_gcc.hpp
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_HPP_INCLUDED_
13 # error "Do not include directly; please include <sensitivityio/config/platform_compiler.hpp> instead!!!"
14 #endif
15
16 #if (!CPPDEVTK_PLATFORM_MACOSX)
17 # error "This file is Mac OS X specific!!!"
18 #endif
19
20 #if (!CPPDEVTK_COMPILER_GCC)
21 # error "This file is GCC specific!!!"
22 #endif
23
24
25 #ifndef SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_MACOSX_GCC_HPP_INCLUDED_
26 #define SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_MACOSX_GCC_HPP_INCLUDED_
27
28
29 #include "unix_gcc.hpp"
30 #include <cppdevtk/config/platform_compiler.hpp>
31
32
34 // Platform Compiler Features.
35
36
37 #endif // SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_MACOSX_GCC_HPP_INCLUDED_
unix_gcc.hpp


sensitivityio: sensitivityio/config/compiler/msvc.hpp Source File

  • config
  • compiler
msvc.hpp
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_CONFIG_COMPILER_HPP_INCLUDED_
13 # error "Do not include directly; please include <sensitivityio/config/compiler.hpp> instead!!!"
14 #endif
15
16
17 #ifndef SENSITIVITYIO_CONFIG_COMPILER_MSVC_HPP_INCLUDED_
18 #define SENSITIVITYIO_CONFIG_COMPILER_MSVC_HPP_INCLUDED_
19
20
22 // SENSITIVITYIO_SHARED and _DLL
23 #if (defined(_DLL) && !defined(SENSITIVITYIO_SHARED))
24 # define SENSITIVITYIO_SHARED
25 #endif
26 #if (defined(SENSITIVITYIO_SHARED) && (!defined(_DLL) || defined(_LIB)))
27 # error "SENSITIVITYIO shared library with static runtime is too dangerous!!!"
28 #endif
29 #ifdef SENSITIVITYIO_SHARED
30 # ifndef CPPDEVTK_SHARED
31 # define CPPDEVTK_SHARED
32 # endif
33 #endif
34
35 #include <cppdevtk/config/compiler.hpp>
36 #ifndef RC_INVOKED
37 #if (!CPPDEVTK_COMPILER_MSVC)
38 # error "This file is MSVC specific!!!"
39 #endif
40 #endif
41
42
44 // Third party warnings.
45 #if (SENSITIVITYIO_DISABLE_THIRD_PARTY_WARNINGS)
46 //# pragma warning(disable: 4127)
47 // TODO: put other third-party warnings safe to disable here.
48 #endif
49
50
52 // sensitivityio warnings.
53 #if (SENSITIVITYIO_DISABLE_SENSITIVITYIO_WARNINGS)
54 #pragma warning(disable: 4514) // C4514: 'fn': unreferenced inline function has been removed
55 #pragma warning(disable: 4710) // C4710: 'fn': function not inlined
56 #pragma warning(disable: 4371) // C4371: 'class': layout of class may have changed from a previous version of the compiler due to better packing of member 'member'
57 #pragma warning(disable: 4623) // C4623: 'class': default constructor was implicitly defined as deleted
58 // TODO: put other sensitivityio warnings safe to disable here.
59 #endif
60
61
63 // Compiler Features.
64 // TODO: test for compiler features here.
65
66
67 #endif // SENSITIVITYIO_CONFIG_COMPILER_MSVC_HPP_INCLUDED_


sensitivityio: sensitivityio/php_base/config.h Source File

  • php_base
config.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_BASE_CONFIG_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_BASE_CONFIG_H_INCLUDED_
14
15
16 #include <sensitivityio/config/config.hpp>
17
18
19 #include <php_version.h>
20 #if (PHP_MAJOR_VERSION == 7)
21 // Ubuntu 16.04 ugly workaround
22 #if (PHP_VERSION_ID >= 70018)
23 # if (defined(__cplusplus) && CPPDEVTK_COMPILER_GCC)
24 # if ((__cplusplus >= 201103L) || defined(__GXX_EXPERIMENTAL_CXX0X__))
25 # include <cmath>
26 using ::std::isfinite;
27 using ::std::isnan;
28 # endif
29 # endif
30 # endif
31 #elif (PHP_MAJOR_VERSION == 5)
32 # if (PHP_MINOR_VERSION < 3)
33 # error "Only PHP 5.x >= 5.3 is supported!!!"
34 # endif
35 #else
36 # error "Only PHP 5 and 7 are supported!!!"
37 #endif
38
39 #include <php.h>
40 #include <zend_modules.h>
41 #ifdef ZTS
42 #include <TSRM.h>
43 #endif
44
45
46 #if (PHP_MAJOR_VERSION == 7)
47 # define SENSITIVITYIO_ZEND_RESOURCE zend_resource
48
49 # define SENSITIVITYIO_ZEND_FETCH_RESOURCE(rsrc, rsrc_type, passed_id, resource_type_name, resource_type) \
50 (rsrc) = (rsrc_type)zend_fetch_resource(Z_RES_P(passed_id), resource_type_name, resource_type)
51
52 # define SENSITIVITYIO_ZEND_REGISTER_RESOURCE(rsrc_result, rsrc_pointer, rsrc_type) \
53 ZVAL_RES(rsrc_result, zend_register_resource(rsrc_pointer, rsrc_type))
54
55 # define SENSITIVITYIO_RETURN_STRING(str, duplicate) \
56 do { \
57 if (duplicate) { \
58 RETURN_STRING(str); \
59 } \
60 else { \
61 RETVAL_STRING(str); \
62 efree((char*)str); \
63 return; \
64 } \
65 } \
66 while (0)
67 #elif (PHP_MAJOR_VERSION == 5)
68 # define SENSITIVITYIO_ZEND_RESOURCE zend_rsrc_list_entry
69
70 # define SENSITIVITYIO_ZEND_FETCH_RESOURCE(rsrc, rsrc_type, passed_id, resource_type_name, resource_type) \
71 ZEND_FETCH_RESOURCE(rsrc, rsrc_type, &(passed_id), -1, resource_type_name, resource_type)
72
73 # define SENSITIVITYIO_ZEND_REGISTER_RESOURCE(rsrc_result, rsrc_pointer, rsrc_type) \
74 ZEND_REGISTER_RESOURCE(rsrc_result, rsrc_pointer, rsrc_type)
75
76 # define SENSITIVITYIO_RETURN_STRING(str, duplicate) RETURN_STRING(str, duplicate)
77 #else
78 # error "Only PHP 5 and 7 are supported!!!"
79 #endif
80
81 // PHP_FE_END was introduced in 5.3.10 and we have 5.3.3 in CentOS 6.6
82 #ifndef PHP_FE_END
83 #define PHP_FE_END {NULL, NULL, NULL, 0, 0}
84 #endif
85
86
87 #ifdef PHP_WIN32
88 # define SENSITIVITYIO_PHP_BASE_API __declspec(dllexport)
89 #elif defined(__GNUC__) && __GNUC__ >= 4
90 # define SENSITIVITYIO_PHP_BASE_API __attribute__ ((visibility("default")))
91 #else
92 # define SENSITIVITYIO_PHP_BASE_API
93 #endif
94
95
96 #define SENSITIVITYIO_PHP_BASE_VERSION SENSITIVITYIO_VERSION_STRING
97
98 #define phpext_sensitivityio_php_base_ptr &sensitivityio_php_base_module_entry
99
100 /* In every utility function you add that needs to use variables
101 in sensitivityio_php_base_globals, call TSRMLS_FETCH(); after declaring other
102 variables used by that function, or better yet, pass in TSRMLS_CC
103 after the last function argument and declare your utility function
104 with TSRMLS_DC after the last declared argument. Always refer to
105 the globals in your function as SENSITIVITYIO_PHP_BASE_G(variable). You are
106 encouraged to rename these macros something shorter, see
107 examples in any other php module directory.
108 */
109 #ifdef ZTS
110 #define SENSITIVITYIO_PHP_BASE_G(v) TSRMG(sensitivityio_php_base_globals_id, zend_sensitivityio_php_base_globals *, v)
111 #else
112 #define SENSITIVITYIO_PHP_BASE_G(v) (sensitivityio_php_base_globals.v)
113 #endif
114
115
116 #endif // SENSITIVITYIO_PHP_BASE_CONFIG_H_INCLUDED_
config.hpp


sensitivityio: sensitivityio/php_base/php_base.h Source File

  • php_base
php_base.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_BASE_PHP_BASE_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_BASE_PHP_BASE_H_INCLUDED_
14
15
16 #include "config.h"
17
18
19 #ifdef __cplusplus
20 extern "C" {
21 #endif
22
23
24 PHP_MINIT_FUNCTION(sensitivityio_php_base);
25 PHP_MSHUTDOWN_FUNCTION(sensitivityio_php_base);
26 PHP_RINIT_FUNCTION(sensitivityio_php_base);
27 PHP_RSHUTDOWN_FUNCTION(sensitivityio_php_base);
28 PHP_MINFO_FUNCTION(sensitivityio_php_base);
29
30
31 /*
32 Declare any global variables you may need between the BEGIN
33 and END macros here:
34
35 ZEND_BEGIN_MODULE_GLOBALS(sensitivityio_php_base)
36 long global_value;
37 char *global_string;
38 ZEND_END_MODULE_GLOBALS(sensitivityio_php_base)
39 */
40
41
42 extern zend_module_entry sensitivityio_php_base_module_entry;
43
44
45 #ifdef __cplusplus
46 }
47 #endif
48
49
50 #endif // SENSITIVITYIO_PHP_BASE_PHP_SDS_H_INCLUDED_
PHP_RSHUTDOWN_FUNCTION
PHP_RSHUTDOWN_FUNCTION(sensitivityio_php_base)
sensitivityio_php_base_module_entry
zend_module_entry sensitivityio_php_base_module_entry
PHP_RINIT_FUNCTION
PHP_RINIT_FUNCTION(sensitivityio_php_base)
PHP_MSHUTDOWN_FUNCTION
PHP_MSHUTDOWN_FUNCTION(sensitivityio_php_base)
PHP_MINFO_FUNCTION
PHP_MINFO_FUNCTION(sensitivityio_php_base)
PHP_MINIT_FUNCTION
PHP_MINIT_FUNCTION(sensitivityio_php_base)
config.h


sensitivityio: sensitivityio/php_license/config.h Source File

  • php_license
config.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_LICENSE_CONFIG_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_LICENSE_CONFIG_H_INCLUDED_
14
15
16 #include <sensitivityio/php_base/config.h>
17
18 #include <php.h>
19 #include <zend_modules.h>
20 #ifdef ZTS
21 #include <TSRM.h>
22 #endif
23
24
25 #ifdef PHP_WIN32
26 # define SENSITIVITYIO_PHP_LICENSE_API __declspec(dllexport)
27 #elif defined(__GNUC__) && __GNUC__ >= 4
28 # define SENSITIVITYIO_PHP_LICENSE_API __attribute__ ((visibility("default")))
29 #else
30 # define SENSITIVITYIO_PHP_LICENSE_API
31 #endif
32
33
34 #define SENSITIVITYIO_PHP_LICENSE_VERSION SENSITIVITYIO_VERSION_STRING
35
36 #define phpext_sensitivityio_php_license_ptr &sensitivityio_php_license_module_entry
37
38 /* In every utility function you add that needs to use variables
39 in sensitivityio_php_license_globals, call TSRMLS_FETCH(); after declaring other
40 variables used by that function, or better yet, pass in TSRMLS_CC
41 after the last function argument and declare your utility function
42 with TSRMLS_DC after the last declared argument. Always refer to
43 the globals in your function as SENSITIVITYIO_PHP_LICENSE_G(variable). You are
44 encouraged to rename these macros something shorter, see
45 examples in any other php module directory.
46 */
47 #ifdef ZTS
48 #define SENSITIVITYIO_PHP_LICENSE_G(v) TSRMG(sensitivityio_php_license_globals_id, zend_sensitivityio_php_license_globals *, v)
49 #else
50 #define SENSITIVITYIO_PHP_LICENSE_G(v) (sensitivityio_php_license_globals.v)
51 #endif
52
53
54 #endif // SENSITIVITYIO_PHP_LICENSE_CONFIG_H_INCLUDED_
config.h


sensitivityio: sensitivityio/php_license/php_license.h Source File

  • php_license
php_license.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_LICENSE_PHP_LICENSE_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_LICENSE_PHP_LICENSE_H_INCLUDED_
14
15
16 #include "config.h"
17
18
19 #ifdef __cplusplus
20 extern "C" {
21 #endif
22
23
24 PHP_MINIT_FUNCTION(sensitivityio_php_license);
25 PHP_MSHUTDOWN_FUNCTION(sensitivityio_php_license);
26 PHP_RINIT_FUNCTION(sensitivityio_php_license);
27 PHP_RSHUTDOWN_FUNCTION(sensitivityio_php_license);
28 PHP_MINFO_FUNCTION(sensitivityio_php_license);
29
30
31 /*
32 Declare any global variables you may need between the BEGIN
33 and END macros here:
34
35 ZEND_BEGIN_MODULE_GLOBALS(sensitivityio_php_license)
36 long global_value;
37 char *global_string;
38 ZEND_END_MODULE_GLOBALS(sensitivityio_php_license)
39 */
40
41
42 extern zend_module_entry sensitivityio_php_license_module_entry;
43
44
45 #ifdef __cplusplus
46 }
47 #endif
48
49
50 #endif // SENSITIVITYIO_PHP_LICENSE_PHP_LICENSE_H_INCLUDED_
PHP_MINFO_FUNCTION
PHP_MINFO_FUNCTION(sensitivityio_php_license)
PHP_RINIT_FUNCTION
PHP_RINIT_FUNCTION(sensitivityio_php_license)
PHP_MINIT_FUNCTION
PHP_MINIT_FUNCTION(sensitivityio_php_license)
PHP_MSHUTDOWN_FUNCTION
PHP_MSHUTDOWN_FUNCTION(sensitivityio_php_license)
sensitivityio_php_license_module_entry
zend_module_entry sensitivityio_php_license_module_entry
PHP_RSHUTDOWN_FUNCTION
PHP_RSHUTDOWN_FUNCTION(sensitivityio_php_license)
config.h


sensitivityio: sensitivityio/php_sdc/config.h Source File

  • php_sdc
config.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_SENSITIVE_DATA_CLASSIFICATION_CONFIG_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_SENSITIVE_DATA_CLASSIFICATION_CONFIG_H_INCLUDED_
14
15
16 #include <sensitivityio/php_license/config.h>
17
18 #include <php.h>
19 #include <zend_modules.h>
20 #ifdef ZTS
21 #include <TSRM.h>
22 #endif
23
24
25 #ifdef PHP_WIN32
26 # define SENSITIVITYIO_PHP_SDC_API __declspec(dllexport)
27 #elif defined(__GNUC__) && __GNUC__ >= 4
28 # define SENSITIVITYIO_PHP_SDC_API __attribute__ ((visibility("default")))
29 #else
30 # define SENSITIVITYIO_PHP_SDC_API
31 #endif
32
33
34 #define SENSITIVITYIO_PHP_SDC_VERSION SENSITIVITYIO_VERSION_STRING
35
36 #define phpext_sensitivityio_php_sdc_ptr &sensitivityio_php_sdc_module_entry
37
38 /* In every utility function you add that needs to use variables
39 in sensitivityio_php_sdc_globals, call TSRMLS_FETCH(); after declaring other
40 variables used by that function, or better yet, pass in TSRMLS_CC
41 after the last function argument and declare your utility function
42 with TSRMLS_DC after the last declared argument. Always refer to
43 the globals in your function as SENSITIVITYIO_PHP_SDC_G(variable). You are
44 encouraged to rename these macros something shorter, see
45 examples in any other php module directory.
46 */
47 #ifdef ZTS
48 #define SENSITIVITYIO_PHP_SDC_G(v) TSRMG(sensitivityio_php_sdc_globals_id, zend_sensitivityio_php_sdc_globals *, v)
49 #else
50 #define SENSITIVITYIO_PHP_SDC_G(v) (sensitivityio_php_sdc_globals.v)
51 #endif
52
53
54 #endif // SENSITIVITYIO_PHP_SENSITIVE_DATA_CLASSIFICATION_CONFIG_H_INCLUDED_
config.h


sensitivityio: sensitivityio/php_sdc/php_sdc.h Source File

  • php_sdc
php_sdc.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_SENSITIVE_DATA_CLASSIFICATION_PHP_SDC_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_SENSITIVE_DATA_CLASSIFICATION_PHP_SDC_H_INCLUDED_
14
15
16 #include "config.h"
17
18
19 #ifdef __cplusplus
20 extern "C" {
21 #endif
22
23
24 PHP_MINIT_FUNCTION(sensitivityio_php_sdc);
25 PHP_MSHUTDOWN_FUNCTION(sensitivityio_php_sdc);
26 PHP_RINIT_FUNCTION(sensitivityio_php_sdc);
27 PHP_RSHUTDOWN_FUNCTION(sensitivityio_php_sdc);
28 PHP_MINFO_FUNCTION(sensitivityio_php_sdc);
29
30
31 /*
32 Declare any global variables you may need between the BEGIN
33 and END macros here:
34
35 ZEND_BEGIN_MODULE_GLOBALS(sensitivityio_php_sdc)
36 long global_value;
37 char *global_string;
38 ZEND_END_MODULE_GLOBALS(sensitivityio_php_sdc)
39 */
40
41
42 extern zend_module_entry sensitivityio_php_sdc_module_entry;
43
44
45 #ifdef __cplusplus
46 }
47 #endif
48
49
50 #endif // SENSITIVITYIO_PHP_SENSITIVE_DATA_CLASSIFICATION_PHP_SDC_H_INCLUDED_
PHP_RINIT_FUNCTION
PHP_RINIT_FUNCTION(sensitivityio_php_sdc)
sensitivityio_php_sdc_module_entry
zend_module_entry sensitivityio_php_sdc_module_entry
config.h
PHP_MSHUTDOWN_FUNCTION
PHP_MSHUTDOWN_FUNCTION(sensitivityio_php_sdc)
PHP_MINIT_FUNCTION
PHP_MINIT_FUNCTION(sensitivityio_php_sdc)
PHP_RSHUTDOWN_FUNCTION
PHP_RSHUTDOWN_FUNCTION(sensitivityio_php_sdc)
PHP_MINFO_FUNCTION
PHP_MINFO_FUNCTION(sensitivityio_php_sdc)


sensitivityio: sensitivityio/php_sds/config.h Source File

  • php_sds
config.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_CONFIG_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_CONFIG_H_INCLUDED_
14
15
16 #include <sensitivityio/php_license/config.h>
17
18 #include <php.h>
19 #include <zend_modules.h>
20 #ifdef ZTS
21 #include <TSRM.h>
22 #endif
23
24
25 #ifdef PHP_WIN32
26 # define SENSITIVITYIO_PHP_SDS_API __declspec(dllexport)
27 #elif defined(__GNUC__) && __GNUC__ >= 4
28 # define SENSITIVITYIO_PHP_SDS_API __attribute__ ((visibility("default")))
29 #else
30 # define SENSITIVITYIO_PHP_SDS_API
31 #endif
32
33
34 #define SENSITIVITYIO_PHP_SDS_VERSION SENSITIVITYIO_VERSION_STRING
35
36 #define phpext_sensitivityio_php_sds_ptr &sensitivityio_php_sds_module_entry
37
38 /* In every utility function you add that needs to use variables
39 in sensitivityio_php_sds_globals, call TSRMLS_FETCH(); after declaring other
40 variables used by that function, or better yet, pass in TSRMLS_CC
41 after the last function argument and declare your utility function
42 with TSRMLS_DC after the last declared argument. Always refer to
43 the globals in your function as SENSITIVITYIO_PHP_SDS_G(variable). You are
44 encouraged to rename these macros something shorter, see
45 examples in any other php module directory.
46 */
47 #ifdef ZTS
48 #define SENSITIVITYIO_PHP_SDS_G(v) TSRMG(sensitivityio_php_sds_globals_id, zend_sensitivityio_php_sds_globals *, v)
49 #else
50 #define SENSITIVITYIO_PHP_SDS_G(v) (sensitivityio_php_sds_globals.v)
51 #endif
52
53
54 #endif // SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_CONFIG_H_INCLUDED_
config.h


sensitivityio: sensitivityio/php_sds/php_sds.h Source File

  • php_sds
php_sds.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_PHP_SDS_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_PHP_SDS_H_INCLUDED_
14
15
16 #include "config.h"
17
18
19 #ifdef __cplusplus
20 extern "C" {
21 #endif
22
23
24 PHP_MINIT_FUNCTION(sensitivityio_php_sds);
25 PHP_MSHUTDOWN_FUNCTION(sensitivityio_php_sds);
26 PHP_RINIT_FUNCTION(sensitivityio_php_sds);
27 PHP_RSHUTDOWN_FUNCTION(sensitivityio_php_sds);
28 PHP_MINFO_FUNCTION(sensitivityio_php_sds);
29
30
31 /*
32 Declare any global variables you may need between the BEGIN
33 and END macros here:
34
35 ZEND_BEGIN_MODULE_GLOBALS(sensitivityio_php_sds)
36 long global_value;
37 char *global_string;
38 ZEND_END_MODULE_GLOBALS(sensitivityio_php_sds)
39 */
40
41
42 extern zend_module_entry sensitivityio_php_sds_module_entry;
43
44
45 #ifdef __cplusplus
46 }
47 #endif
48
49
50 #endif // SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_PHP_SDS_H_INCLUDED_
PHP_RINIT_FUNCTION
PHP_RINIT_FUNCTION(sensitivityio_php_sds)
PHP_RSHUTDOWN_FUNCTION
PHP_RSHUTDOWN_FUNCTION(sensitivityio_php_sds)
PHP_MINIT_FUNCTION
PHP_MINIT_FUNCTION(sensitivityio_php_sds)
config.h
sensitivityio_php_sds_module_entry
zend_module_entry sensitivityio_php_sds_module_entry
PHP_MSHUTDOWN_FUNCTION
PHP_MSHUTDOWN_FUNCTION(sensitivityio_php_sds)
PHP_MINFO_FUNCTION
PHP_MINFO_FUNCTION(sensitivityio_php_sds)


sensitivityio: sensitivityio/config/platform.hpp Source File

  • config
platform.hpp
Go to the documentation of this file.
1
11
12 #ifdef APSTUDIO_INVOKED
13 # error "This file is not editable by Microsoft Visual C++!!!"
14 #endif
15
16
17 #ifndef SENSITIVITYIO_CONFIG_PLATFORM_HPP_INCLUDED_
18 #define SENSITIVITYIO_CONFIG_PLATFORM_HPP_INCLUDED_
19
20
21 #include "features.hpp"
22 #include "compiler.hpp"
23
24
25 #ifndef RC_INVOKED
26
27 #if ((defined(__APPLE__) && defined(__MACH__)) /* && TARGET_OS_MAC */)
28 // Mac OS X is Unix
29 # ifndef __unix__
30 # define __unix__
31 # endif
32 # ifndef __unix
33 # define __unix
34 # endif
35 #endif
36
37 #if (defined(__unix__) || defined(__unix))
38 # include "platform/unix.hpp"
39 # if (defined(__linux__) || defined(linux) || defined(__linux))
40 # include "platform/linux.hpp"
41 # elif (defined(__APPLE__) && defined(__MACH__))
42 # include "platform/macosx.hpp"
43 # else
44 # error "Unsupported Unix platform!!!"
45 # endif
46 #elif (defined(_WIN32))
47 # include "platform/windows.hpp"
48 #else
49 # error "Unsupported platform!!!"
50 #endif
51
52 #endif // !RC_INVOKED
53
54
55 #include <cppdevtk/config/platform.hpp>
56
57
58 #endif // SENSITIVITYIO_CONFIG_PLATFORM_HPP_INCLUDED_
windows.hpp
unix.hpp
linux.hpp
compiler.hpp
macosx.hpp
features.hpp


sensitivityio: sensitivityio/config/platform_compiler.hpp Source File

  • config
platform_compiler.hpp
Go to the documentation of this file.
1
11
12 #ifdef APSTUDIO_INVOKED
13 # error "This file is not editable by Microsoft Visual C++!!!"
14 #endif
15
16
17 #ifndef SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_HPP_INCLUDED_
18 #define SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_HPP_INCLUDED_
19
20
21 #include "features.hpp"
22 #include "compiler.hpp"
23 #include "platform.hpp"
24
25
26 #ifndef RC_INVOKED
27
28 #if (CPPDEVTK_PLATFORM_UNIX)
29 # if (CPPDEVTK_COMPILER_GCC)
30 # include "platform_compiler/unix_gcc.hpp"
31 # elif (CPPDEVTK_COMPILER_CLANG)
32 # include "platform_compiler/unix_clang.hpp"
33 # else
34 # error "Unsupported compiler for Unix platform!!!"
35 # endif
36
37 # if (CPPDEVTK_PLATFORM_LINUX)
38 # if (CPPDEVTK_COMPILER_GCC)
39 # include "platform_compiler/linux_gcc.hpp"
40 # else
41 # error "Unsupported compiler for Linux platform!!!"
42 # endif
43 # elif (CPPDEVTK_PLATFORM_MACOSX)
44 # if (CPPDEVTK_COMPILER_GCC)
45 # include "platform_compiler/macosx_gcc.hpp"
46 # elif (CPPDEVTK_COMPILER_CLANG)
47 # include "platform_compiler/macosx_clang.hpp"
48 # else
49 # error "Unsupported compiler for Mac OS X platform!!!"
50 # endif
51 # else
52 # error "Unsupported Unix platform!!!"
53 # endif
54 #elif (CPPDEVTK_PLATFORM_WINDOWS)
55 # if (CPPDEVTK_COMPILER_MSVC)
56 # include "platform_compiler/windows_msvc.hpp"
57 # else
58 # error "Unsupported compiler for Windows platform!!!"
59 # endif
60 #else
61 # error "Unsupported platform!!!"
62 #endif
63
64 #endif // !RC_INVOKED
65
66
67 #include <cppdevtk/config/platform_compiler.hpp>
68
69
70 #endif // SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_HPP_INCLUDED_
unix_gcc.hpp
platform.hpp
windows_msvc.hpp
compiler.hpp
unix_clang.hpp
linux_gcc.hpp
features.hpp
macosx_gcc.hpp
macosx_clang.hpp


sensitivityio: sensitivityio/config/product_info.hpp Source File

  • config
product_info.hpp
Go to the documentation of this file.
1
11
12 #ifdef APSTUDIO_INVOKED
13 # error "This file is not editable by Microsoft Visual C++!!!"
14 #endif
15
16
17 #ifndef SENSITIVITYIO_CONFIG_PRODUCT_INFO_HPP_INCLUDED_
18 #define SENSITIVITYIO_CONFIG_PRODUCT_INFO_HPP_INCLUDED_
19
20
21 #include "features.hpp"
22
23 #include <cppdevtk/config/info.hpp>
24
25
26 // Version format: MM.mm.pp.
27 // In places where version has 4 numbers the fourth (last significant) number will be always 1.
28 // Semantic Versioning http://semver.org
29 // TODO: keep updated
30 #define SENSITIVITYIO_VERSION_MAJOR 1
31 #define SENSITIVITYIO_VERSION_MINOR 1
32 #define SENSITIVITYIO_VERSION_PATCH 1
33 #ifdef _WIN32
34 #define SENSITIVITYIO_VERSION_BUILD 1
35 #endif
36
37
38 #define SENSITIVITYIO_VERSION_NUMBER \
39 CPPDEVTK_VERSION_NUMBER_FROM_COMPONENTS(SENSITIVITYIO_VERSION_MAJOR, SENSITIVITYIO_VERSION_MINOR, SENSITIVITYIO_VERSION_PATCH)
40
41 #define SENSITIVITYIO_VERSION_STRING \
42 CPPDEVTK_VERSION_STRING_FROM_COMPONENTS(SENSITIVITYIO_VERSION_MAJOR, SENSITIVITYIO_VERSION_MINOR, SENSITIVITYIO_VERSION_PATCH)
43
44
45 #define SENSITIVITYIO_SHORT_NAME "sensitivityio"
46 #define SENSITIVITYIO_SHORT_NAME_SANITIZED QString(SENSITIVITYIO_SHORT_NAME).toLower().replace(' ', '_')
47 #define SENSITIVITYIO_LONG_NAME "sensitivity.io - Data Loss Prevention APIs for Developers"
48 #define SENSITIVITYIO_LONG_NAME_SANITIZED QString(SENSITIVITYIO_LONG_NAME).toLower().replace(' ', '_')
49 #define SENSITIVITYIO_DESCRIPTION "sensitivity.io is a Security as a Service Platform."
50 #define SENSITIVITYIO_COPYRIGHT "Copyright (C) 2017 " CPPDEVTK_COMPANY_LONG_NAME ". All rights reserved. " CPPDEVTK_COMPANY_EMAIL "."
51 #define SENSITIVITYIO_TRADEMARKS CPPDEVTK_COMPANY_TRADEMARKS
52 #define SENSITIVITYIO_HOMEPAGE "https://sensitivity.io"
53 #define SENSITIVITYIO_ONLINE_SUPPORT "https://sensitivity.io/support"
54 #define SENSITIVITYIO_ONLINE_REGISTRATION "https://sensitivity.io/register"
55 #define SENSITIVITYIO_ESTORE "https://sensitivity.io/buy"
56 #define SENSITIVITYIO_EMAIL "team@sensitivity.io"
57
58
59 #endif // SENSITIVITYIO_CONFIG_PRODUCT_INFO_HPP_INCLUDED_
features.hpp


sensitivityio: sensitivityio/php_sds/scanner.h Source File

  • php_sds
scanner.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_SCANNER_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_SCANNER_H_INCLUDED_
14
15
16 #include "config.h"
17 #include "threat_info.h"
18 #include "threat_infos.h"
19
20
21 #define SENSITIVITYIO_PHP_SDS_SCANNER_RES_NAME "SENSITIVITYIO_PHP_SDS_SCANNER"
22
23
24 #ifdef __cplusplus
25 extern "C" {
26 #endif
27
28
30 PHP_FUNCTION(sensitivityio_php_sds_scanner_create);
31
36 PHP_FUNCTION(sensitivityio_php_sds_scanner_scan_string_th);
37
43 PHP_FUNCTION(sensitivityio_php_sds_scanner_scan_buffer_th);
44
49 PHP_FUNCTION(sensitivityio_php_sds_scanner_scan_file_th);
50
55 PHP_FUNCTION(sensitivityio_php_sds_scanner_scan_string);
56
62 PHP_FUNCTION(sensitivityio_php_sds_scanner_scan_buffer);
63
68 PHP_FUNCTION(sensitivityio_php_sds_scanner_scan_file);
69
70
71 extern int le_sensitivityio_php_sds_scanner;
72
73
74 #ifdef __cplusplus
75 }
76 #endif
77
78
79 #endif // SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_SCANNER_H_INCLUDED_
threat_infos.h
config.h
PHP_FUNCTION
PHP_FUNCTION(sensitivityio_php_sds_scanner_create)
sensitivityio_php_sds_scanner_t sensitivityio_php_sds_scanner_create();
threat_info.h
le_sensitivityio_php_sds_scanner
int le_sensitivityio_php_sds_scanner


sensitivityio: sensitivityio/php_sds/scanner_settings_loader.h Source File

  • php_sds
scanner_settings_loader.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_SCANNER_SETTINGS_LOADER_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_SCANNER_SETTINGS_LOADER_H_INCLUDED_
14
15
16 #include "config.h"
17 #include <sensitivityio/php_license/settings_loader.h>
18 #include "scanner.h"
19
20
21 #ifdef __cplusplus
22 extern "C" {
23 #endif
24
25
27 PHP_FUNCTION(sensitivityio_php_sds_scanner_settings_loader_create);
28
29
32 PHP_FUNCTION(sensitivityio_php_sds_scanner_settings_loader_is_scanner_registered);
33
37 PHP_FUNCTION(sensitivityio_php_sds_scanner_settings_loader_register_scanner);
38
42 PHP_FUNCTION(sensitivityio_php_sds_scanner_settings_loader_unregister_scanner);
43
44
45 #ifdef __cplusplus
46 }
47 #endif
48
49
50 #endif // SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_SCANNER_SETTINGS_LOADER_H_INCLUDED_
config.h
settings_loader.h
scanner.h
PHP_FUNCTION
PHP_FUNCTION(sensitivityio_php_sds_scanner_settings_loader_create)
sensitivityio_php_settings_loader_t sensitivityio_php_sds_scanner_settings_loader_create(void); ...


sensitivityio: sensitivityio/php_sds/scanner_settings_retriever.h Source File

  • php_sds
scanner_settings_retriever.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_SCANNER_SETTINGS_RETRIEVER_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_SCANNER_SETTINGS_RETRIEVER_H_INCLUDED_
14
15
16 #include "config.h"
17 #include "scanner_settings_loader.h"
18 #include <sensitivityio/php_license/settings_retriever.h>
19
20
21 #ifdef __cplusplus
22 extern "C" {
23 #endif
24
25
27 PHP_FUNCTION(sensitivityio_php_sds_scanner_settings_retriever_create);
28
29
30 #ifdef __cplusplus
31 }
32 #endif
33
34
35 #endif // SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_SCANNER_SETTINGS_RETRIEVER_H_INCLUDED_
scanner_settings_loader.h
PHP_FUNCTION
PHP_FUNCTION(sensitivityio_php_sds_scanner_settings_retriever_create)
sensitivityio_php_http_retriever_t sensitivityio_php_sds_scanner_settings_retriever_create(); ...
settings_retriever.h
config.h


sensitivityio: sensitivityio/php_sds/sds_threat_type.h Source File

  • php_sds
sds_threat_type.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_SDS_THREAT_TYPE_INCLUDED_
13 #define SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_SDS_THREAT_TYPE_INCLUDED_
14
15
16 #include "config.h"
17
18
19 #ifdef __cplusplus
20 extern "C" {
21 #endif
22
23
25 PHP_FUNCTION(sensitivityio_php_sds_get_threat_type_name);
26
27
28 #ifdef __cplusplus
29 }
30 #endif
31
32
33 #endif // SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_SDS_THREAT_TYPE_INCLUDED_
config.h
PHP_FUNCTION
PHP_FUNCTION(sensitivityio_php_sds_get_threat_type_name)
string sensitivityio_php_sds_get_threat_type_name(sensitivityio_sds_threat_type_id_t $threatTypeId); ...


sensitivityio: sensitivityio/php_license/settings_loader.h Source File

  • php_license
settings_loader.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_LICENSE_SETTINGS_LOADER_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_LICENSE_SETTINGS_LOADER_H_INCLUDED_
14
15
16 #include "config.h"
17
18
19 #define SENSITIVITYIO_PHP_SETTINGS_LOADER_RES_NAME "SENSITIVITYIO_PHP_SETTINGS_LOADER"
20
21
22 #ifdef __cplusplus
23 extern "C" {
24 #endif
25
26
30 PHP_FUNCTION(sensitivityio_php_settings_loader_load_settings_from_string);
31
35 PHP_FUNCTION(sensitivityio_php_settings_loader_load_settings_from_file);
36
37
38 extern int le_sensitivityio_php_settings_loader;
39
40
41 #ifdef __cplusplus
42 }
43 #endif
44
45
46 #endif // SENSITIVITYIO_PHP_LICENSE_SETTINGS_LOADER_H_INCLUDED_
PHP_FUNCTION
PHP_FUNCTION(sensitivityio_php_settings_loader_load_settings_from_string)
boolean sensitivityio_php_settings_loader_load_settings_from_string( sensitivityio_php_settings_loade...
le_sensitivityio_php_settings_loader
int le_sensitivityio_php_settings_loader
config.h


sensitivityio: sensitivityio/php_license/settings_retriever.h Source File

  • php_license
settings_retriever.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_LICENSE_SETTINGS_RETRIEVER_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_LICENSE_SETTINGS_RETRIEVER_H_INCLUDED_
14
15
16 #include "config.h"
17 #include "settings_loader.h"
18 #include <sensitivityio/php_base/http_retriever.h>
19
20
21 #ifdef __cplusplus
22 extern "C" {
23 #endif
24
25
28 PHP_FUNCTION(sensitivityio_php_settings_retriever_set_settings_loader);
29
34 PHP_FUNCTION(sensitivityio_php_settings_retriever_retrieve_to_string_and_notify_loader);
35
40 PHP_FUNCTION(sensitivityio_php_settings_retriever_retrieve_to_file_and_notify_loader);
41
42
43 #ifdef __cplusplus
44 }
45 #endif
46
47
48 #endif // SENSITIVITYIO_PHP_LICENSE_SETTINGS_RETRIEVER_H_INCLUDED_
http_retriever.h
config.h
settings_loader.h
PHP_FUNCTION
PHP_FUNCTION(sensitivityio_php_settings_retriever_set_settings_loader)
boolean sensitivityio_php_settings_retriever_set_settings_loader(sensitivityio_php_http_retriever_t $...


sensitivityio: sensitivityio/config/third_party.hpp Source File

  • config
third_party.hpp
Go to the documentation of this file.
1
11
12 #ifdef APSTUDIO_INVOKED
13 # error "This file is not editable by Microsoft Visual C++!!!"
14 #endif
15
16
17 #ifndef SENSITIVITYIO_CONFIG_THIRD_PARTY_HPP_INCLUDED_
18 #define SENSITIVITYIO_CONFIG_THIRD_PARTY_HPP_INCLUDED_
19
20
21 #include "features.hpp"
22 #include "platform_compiler.hpp"
23
24
25 #define SENSITIVITYIO_HAVE_CHARDET 0
26 #define SENSITIVITYIO_HAVE_CURL 1
27
28
29 #if (SENSITIVITYIO_HAVE_CURL)
30 # include <curl/curlver.h>
31 #endif
32
33
34 #if (CPPDEVTK_PLATFORM_WINDOWS)
35 # ifdef SENSITIVITYIO_SHARED
36 # ifndef ZLIB_WINAPI
37 # define ZLIB_WINAPI
38 # endif
39 # ifndef ZLIB_DLL
40 # define ZLIB_DLL
41 # endif
42 # else
43 # if (!PCRE_STATIC)
44 # undef PCRE_STATIC
45 # define PCRE_STATIC 1
46 # endif
47 # endif
48 #endif
49
50
51 #if (SENSITIVITYIO_HAVE_CURL)
52 # ifndef CURL_VERSION_BITS
53 # define CURL_VERSION_BITS(x,y,z) ((x)<<16|(y)<<8|z)
54 # endif
55 # ifndef CURL_AT_LEAST_VERSION
56 # define CURL_AT_LEAST_VERSION(x,y,z) (LIBCURL_VERSION_NUM >= CURL_VERSION_BITS(x, y, z))
57 # endif
58 # if (!CURL_AT_LEAST_VERSION(7, 19, 7))
59 # error "libcurl >= 7.19.7 required!!!"
60 # endif
61
62 # if (CPPDEVTK_PLATFORM_WINDOWS)
63 # ifndef SENSITIVITYIO_SHARED
64 # ifndef CURL_STATICLIB
65 # define CURL_STATICLIB
66 # endif
67 # endif
68 # endif
69 #endif
70
71 // Crypto++
72 // Note: do not include Crypto++ headers here; they triger lots of
73 // C4265: 'class' : class has virtual functions, but destructor is not virtual
74 // Crypto++ version check is made in cryptopp_dll.cpp
75 #ifdef SENSITIVITYIO_DETAIL_BUILD
76 # ifdef __cplusplus
77 # if (CPPDEVTK_PLATFORM_MACOSX && !CPPDEVTK_PLATFORM_IOS)
78 # ifndef CRYPTOPP_DISABLE_ASM
79 //# define CRYPTOPP_DISABLE_ASM
80 # endif
81 # endif
82 # if (CPPDEVTK_PLATFORM_WINDOWS && SENSITIVITYIO_SHARED)
83 # ifndef CRYPTOPP_IMPORTS
84 # define CRYPTOPP_IMPORTS
85 # endif
86 //# include <cryptopp/dll.h> // must be the first Crypto++ header included!
87 # endif
88 //# include <cryptopp/config.h>
89 //# if (CRYPTOPP_VERSION <= 560)
90 //# error "Crypto++ < 560 is not supported!!!"
91 //# endif
92 # endif
93 #endif
94
95
96 #ifdef __cplusplus
97
98 #include <QtCore/QtGlobal>
99
100 #if (QT_VERSION < (QT_VERSION_CHECK(5, 6, 1)) || (QT_VERSION >= QT_VERSION_CHECK(6, 0, 0)))
101 # error "Qt 5 >= 5.6.1 required!!!"
102 #endif
103
104 #endif // __cplusplus
105
106
107 #define SENSITIVITYIO_HAVE_APACHE_TIKA (1 && SENSITIVITYIO_BASE_ENABLE_JNI)
108
109
110 #include <cppdevtk/config/third_party.hpp>
111
112
113 #endif // SENSITIVITYIO_CONFIG_THIRD_PARTY_HPP_INCLUDED_
platform_compiler.hpp
features.hpp


sensitivityio: sensitivityio/php_sds/threat_info.h Source File

  • php_sds
threat_info.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_THREAT_INFO_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_THREAT_INFO_H_INCLUDED_
14
15
16 #include "config.h"
17 #include "threat_location.h"
18
19
20 #define SENSITIVITYIO_PHP_SDS_THREAT_INFO_RES_NAME "SENSITIVITYIO_PHP_SDS_THREAT_INFO"
21
22
23 #ifdef __cplusplus
24 extern "C" {
25 #endif
26
27
30 PHP_FUNCTION(sensitivityio_php_sds_threat_info_set_threat_type_id);
31
34 PHP_FUNCTION(sensitivityio_php_sds_threat_info_get_threat_type_id);
35
38 PHP_FUNCTION(sensitivityio_php_sds_threat_info_set_matched_text);
39
41 PHP_FUNCTION(sensitivityio_php_sds_threat_info_get_matched_text);
42
44 PHP_FUNCTION(sensitivityio_php_sds_threat_info_get_masked_matched_text);
45
48 PHP_FUNCTION(sensitivityio_php_sds_threat_info_set_threat_description);
49
51 PHP_FUNCTION(sensitivityio_php_sds_threat_info_get_threat_description);
52
55 PHP_FUNCTION(sensitivityio_php_sds_threat_info_set_threat_location);
56
59 PHP_FUNCTION(sensitivityio_php_sds_threat_info_get_threat_location);
60
62 PHP_FUNCTION(sensitivityio_php_sds_threat_info_to_string);
63
65 PHP_FUNCTION(sensitivityio_php_sds_threat_info_to_masked_string);
66
68 PHP_FUNCTION(sensitivityio_php_sds_threat_info_st_get_masked_matched_text);
69
70
71 extern int le_sensitivityio_php_sds_threat_info;
72
73
74 #ifdef __cplusplus
75 }
76 #endif
77
78
79 #endif // SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_THREAT_INFO_H_INCLUDED_
threat_location.h
PHP_FUNCTION
PHP_FUNCTION(sensitivityio_php_sds_threat_info_set_threat_type_id)
boolean sensitivityio_php_sds_threat_info_set_threat_type_id(sensitivityio_php_sds_threat_info_t $thr...
le_sensitivityio_php_sds_threat_info
int le_sensitivityio_php_sds_threat_info
config.h


sensitivityio: sensitivityio/php_sds/threat_infos.h Source File

  • php_sds
threat_infos.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_THREAT_INFOS_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_THREAT_INFOS_H_INCLUDED_
14
15
16 #include "config.h"
17 #include "threat_info.h"
18
19
20 #define SENSITIVITYIO_PHP_SDS_THREAT_INFOS_RES_NAME "SENSITIVITYIO_PHP_SDS_THREAT_INFOS"
21
22
23 #ifdef __cplusplus
24 extern "C" {
25 #endif
26
27
29 PHP_FUNCTION(sensitivityio_php_sds_threat_infos_get_size);
30
33 PHP_FUNCTION(sensitivityio_php_sds_threat_infos_get_element);
34
37 PHP_FUNCTION(sensitivityio_php_sds_threat_infos_append_element);
38
40 PHP_FUNCTION(sensitivityio_php_sds_threat_infos_clear);
41
42
43 extern int le_sensitivityio_php_sds_threat_infos;
44
45
46 #ifdef __cplusplus
47 }
48 #endif
49
50
51 #endif // SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_THREAT_INFOS_H_INCLUDED_
PHP_FUNCTION
PHP_FUNCTION(sensitivityio_php_sds_threat_infos_get_size)
boolean sensitivityio_php_sds_threat_infos_get_size(sensitivityio_php_sds_threat_infos_t $threatInfos...
config.h
threat_info.h
le_sensitivityio_php_sds_threat_infos
int le_sensitivityio_php_sds_threat_infos


sensitivityio: sensitivityio/php_sds/threat_location.h Source File

  • php_sds
threat_location.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_THREAT_LOCATION_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_THREAT_LOCATION_H_INCLUDED_
14
15
16 #include "config.h"
17
18
19 #define SENSITIVITYIO_PHP_SDS_THREAT_LOCATION_RES_NAME "SENSITIVITYIO_PHP_SDS_THREAT_LOCATION"
20
21
22 #ifdef __cplusplus
23 extern "C" {
24 #endif
25
26
29 PHP_FUNCTION(sensitivityio_php_sds_threat_location_set_file_name);
30
33 PHP_FUNCTION(sensitivityio_php_sds_threat_location_get_file_name);
34
37 PHP_FUNCTION(sensitivityio_php_sds_threat_location_set_archive_member);
38
41 PHP_FUNCTION(sensitivityio_php_sds_threat_location_get_archive_member);
42
45 PHP_FUNCTION(sensitivityio_php_sds_threat_location_set_offset);
46
49 PHP_FUNCTION(sensitivityio_php_sds_threat_location_get_offset);
50
53 PHP_FUNCTION(sensitivityio_php_sds_threat_location_set_line_number);
54
57 PHP_FUNCTION(sensitivityio_php_sds_threat_location_get_line_number);
58
61 PHP_FUNCTION(sensitivityio_php_sds_threat_location_set_surrounding_text);
62
65 PHP_FUNCTION(sensitivityio_php_sds_threat_location_get_surrounding_text);
66
69 PHP_FUNCTION(sensitivityio_php_sds_threat_location_to_string);
70
71
72 extern int le_sensitivityio_php_sds_threat_location;
73
74
75 #ifdef __cplusplus
76 }
77 #endif
78
79
80 #endif // SENSITIVITYIO_PHP_SENSITIVE_DATA_SCANNER_THREAT_LOCATION_H_INCLUDED_
PHP_FUNCTION
PHP_FUNCTION(sensitivityio_php_sds_threat_location_set_file_name)
boolean sensitivityio_php_sds_threat_location_set_file_name( sensitivityio_php_sds_threat_location_t ...
le_sensitivityio_php_sds_threat_location
int le_sensitivityio_php_sds_threat_location
config.h


sensitivityio: sensitivityio/config/platform/unix.hpp Source File

  • config
  • platform
unix.hpp
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_CONFIG_PLATFORM_HPP_INCLUDED_
13 # error "Do not include directly; please include <sensitivityio/config/platform.hpp> instead!!!"
14 #endif
15
16
17 #ifndef SENSITIVITYIO_CONFIG_PLATFORM_UNIX_HPP_INCLUDED_
18 #define SENSITIVITYIO_CONFIG_PLATFORM_UNIX_HPP_INCLUDED_
19
20
21 #if 0
22
23 #include <unistd.h>
24
25 #include <cppdevtk/config/platform.hpp>
26 #if (!CPPDEVTK_PLATFORM_UNIX)
27 # error "This file is Unix specific!!!"
28 #endif
29
30 #endif
31
32
34 // Platform Features.
35 // TODO: test for platform features here
36
37
38 #endif // SENSITIVITYIO_CONFIG_PLATFORM_UNIX_HPP_INCLUDED_


sensitivityio: sensitivityio/config/platform_compiler/unix_clang.hpp Source File

  • config
  • platform_compiler
unix_clang.hpp
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_HPP_INCLUDED_
13 # error "Do not include directly; please include <sensitivityio/config/platform_compiler.hpp> instead!!!"
14 #endif
15
16 #if (!CPPDEVTK_PLATFORM_UNIX)
17 # error "This file is Unix specific!!!"
18 #endif
19
20 #if (!CPPDEVTK_COMPILER_CLANG)
21 # error "This file is Clang specific!!!"
22 #endif
23
24
25 #ifndef SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_UNIX_CLANG_HPP_INCLUDED_
26 #define SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_UNIX_CLANG_HPP_INCLUDED_
27
28
29 //#include <cppdevtk/config/platform_compiler.hpp>
30
31
33 // Platform Compiler Features.
34
35
36 #endif // SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_UNIX_CLANG_HPP_INCLUDED_


sensitivityio: sensitivityio/config/platform_compiler/unix_gcc.hpp Source File

  • config
  • platform_compiler
unix_gcc.hpp
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_HPP_INCLUDED_
13 # error "Do not include directly; please include <sensitivityio/config/platform_compiler.hpp> instead!!!"
14 #endif
15
16 #if (!CPPDEVTK_PLATFORM_UNIX)
17 # error "This file is Unix specific!!!"
18 #endif
19
20 #if (!CPPDEVTK_COMPILER_GCC)
21 # error "This file is GCC specific!!!"
22 #endif
23
24
25 #ifndef SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_UNIX_GCC_HPP_INCLUDED_
26 #define SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_UNIX_GCC_HPP_INCLUDED_
27
28
29 //#include <cppdevtk/config/platform_compiler.hpp>
30
31
33 // Platform Compiler Features.
34
35
36 #endif // SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_UNIX_GCC_HPP_INCLUDED_


sensitivityio: sensitivityio/php_base/version.h Source File

  • php_base
version.h
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_PHP_BASE_VERSION_H_INCLUDED_
13 #define SENSITIVITYIO_PHP_BASE_VERSION_H_INCLUDED_
14
15
16 #include "config.h"
17
18
19 #ifdef __cplusplus
20 extern "C" {
21 #endif
22
23
25 PHP_FUNCTION(sensitivityio_php_get_version_major);
26
28 PHP_FUNCTION(sensitivityio_php_get_version_minor);
29
31 PHP_FUNCTION(sensitivityio_php_get_version_patch);
32
34 PHP_FUNCTION(sensitivityio_php_get_version_number);
35
37 PHP_FUNCTION(sensitivityio_php_get_version_string);
38
39
40 #ifdef __cplusplus
41 }
42 #endif
43
44
45 #endif // SENSITIVITYIO_PHP_BASE_VERSION_H_INCLUDED_
PHP_FUNCTION
PHP_FUNCTION(sensitivityio_php_get_version_major)
integer sensitivityio_php_get_version_major();
config.h


sensitivityio: sensitivityio/config/platform/windows.hpp Source File

  • config
  • platform
windows.hpp
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_CONFIG_PLATFORM_HPP_INCLUDED_
13 # error "Do not include directly; please include <sensitivityio/config/platform.hpp> instead!!!"
14 #endif
15
16
17 #ifndef SENSITIVITYIO_CONFIG_PLATFORM_WINDOWS_HPP_INCLUDED_
18 #define SENSITIVITYIO_CONFIG_PLATFORM_WINDOWS_HPP_INCLUDED_
19
20
22 // Other Windows specific defines
23 // TODO: put Windows specific defines here
24
25
26 #include <cppdevtk/config/platform.hpp>
27 #if (!CPPDEVTK_PLATFORM_WINDOWS)
28 # error "This file is Windows specific!!!"
29 #endif
30
31
33 // Platform Features.
34 // TODO: test for platform features here
35
36
37 #endif // SENSITIVITYIO_CONFIG_PLATFORM_WINDOWS_HPP_INCLUDED_


sensitivityio: sensitivityio/config/platform_compiler/windows_msvc.hpp Source File

  • config
  • platform_compiler
windows_msvc.hpp
Go to the documentation of this file.
1
11
12 #ifndef SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_HPP_INCLUDED_
13 # error "Do not include directly; please include <sensitivityio/config/platform_compiler.hpp> instead!!!"
14 #endif
15
16 #if (!CPPDEVTK_PLATFORM_WINDOWS)
17 # error "This file is Windows specific!!!"
18 #endif
19
20 #ifndef RC_INVOKED
21 #if (!CPPDEVTK_COMPILER_MSVC)
22 # error "This file is MSVC specific!!!"
23 #endif
24 #endif
25
26
27 #ifndef SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_WINDOWS_MSVC_HPP_INCLUDED_
28 #define SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_WINDOWS_MSVC_HPP_INCLUDED_
29
30
31 #include <cppdevtk/config/platform_compiler.hpp>
32
33
35 // Platform Compiler Features.
36
37
38 #endif // SENSITIVITYIO_CONFIG_PLATFORM_COMPILER_WINDOWS_MSVC_HPP_INCLUDED_